File is open in Audacity when it is not

Im not sure about this feature as I am quite new to Audacity, but just for confirmation that I am not missing something.

I am moving audio files a lot with small editing/exporting in Audacity, I do not save projects as they are small and never repeated.
When I have Audacity open, I open original audio file (file>open) it opens new window, I edit it, I export it, I close it (save project>No). Now I need to move original, but it is still locked until I close Audacity completely (if the first empty window is still open).

Is it standard behavior or there is way around it?

I’m not on Windows, but try this:
“Edit menu > Preferences > Import/Export”
Enable the option “Make copy of uncompressed audio files before editing (safer)”
Click the OK button.

Thanks steve for quick reply, but unfortunately ist not that. setting was Enabled all time.

What version of Audacity are you using? Please give us all three numbers, see the pink panel at the top of the page.

If the files are those that FFmpeg needs to import then it’s a known issue, though in the current 2.1.3 release from I don’t see it happening.

Of course you can use an Unlock tool (like “Unlocker”, but don’t use that because they changed to bundling malware and it is hard to find copies without that infection).


My bad, Im using 2.1.2 exe installer.
After your post, I downloaded and tried zip of 2.1.3.
It seems the problem is gone. I will try to update and work with new version.
Thanks guys.

Were these files requiring FFmpeg - files like WMA, MP4/M4A or AC3?

If that is the problem we did not consciously fix it, though for 2.1.3 we did make improvements in removing memory leaks that would hang on to memory when it was no longer required.

Note that Audacity does not “open” files - it makes a high quality copy of them by default, or for WAV/AIFF it can optionally read the file from where it is. Accordingly the file is not (or should not be) locked, and you could delete the original file as soon as you have imported it. Obviously don’t do that unless you know what you are doing.


To be honest I am not very familiar with multimedia as I am doing different line of work, but files I am usually opening with Audacity are AMR and sometimes MP3.
I did not noticed that behavior using MP3 files (just tried again and it is fine with my 2.1.2), but the AMR files (phone recordings, samr) becomes locked like I mentioned.

If you are importing AMR files then you must by definition have installed FFmpeg or the files would not import. FFmpeg could import MP3 if you chose, but you don’t need FFmpeg to import or export MP3.

I don’t think the locking occurred other than with FFmpeg. I tried importing an AMR file. For me on Windows 10 x64, the file gets locked in 2.1.2 but not in 2.1.3.


Yes, its true. I installed installed FFmpeg on previous version.
2.1.3 seems working fine.
Thanks, Gale.