File Error message

While recording, getting a “File Error” message saying “Audacity failed to write a file. Perhaps /User/… is not writable or the disk is full”

Audacity tells me there is a remaining of 66 hours of recording and as per the system, I still have 519 Gb free on the hard disk.

Mac OS 10.15.5
Audacity 2.4.1

What is the file name you are attempting to write to. Is this during recording, when saving a project, or when exporting a project?
– Bill

Error message during the recording

What is the file name you are attempting to write to?

What is the full error message after “/User/”?

Do you get this error message immediately when you start recording, or after some time?

– Bill

What is the file name you are attempting to write to?

Never reach this steps, getting the error way before the end of the recording.

What is the full error message after “/User/”?

This is the full path where the application is creating the temp files.

Do you get this error message immediately when you start recording, or after some time?

Getting the error while recording, some time after few seconds, other times after 2 or 3 min of recording.

Audacity should be attempting to write to /User//Library/Application Support/audacity/SessionData/

Please check in Audacity > Preferences > Directories that this is the location of the temporary files.

If not, use the “Choose” button to navigate to the SessionData folder and choose it as the temp files location. If the folder does not exist, create it.

If the “audacity” folder does not exist inside “Application Support”, please follow the instruction in this forum post to reset your Audacity settings. You only need to delete the “audacity.cfg” file. You do not need to delete the “pluginsettings” and “pluginregistry” files.

– Bill

Audacity should be attempting to write to /User//Library/Application Support/audacity/SessionData/

This is where it sets to.

Then this is a mystery to me. Audacity is saying it does not have permission to write to the location. But Audacity can write to the audacity.cfg file and other files in Application Support/audacity .

Maybe some other forum elf will have another perspective on this.

– Bill

I have been having this same problem for some time as well.

I still don’t know what could be causing this, but this workaround should work.

Before you begin recording Save the project into your Documents folder. That way Audacity will not be attempting to write to the SessionData folder.

– Bill

My problem is a little different. I can’t open any projects either. I get the error when I open any file.

This was my original post.

So far I’ve tried:

  • delete app and reinstall [several times, but I haven’t since the 2.4.1 update yet]
  • change location of temp folder
  • reinstall MacOs [several times]
  • Changing permissions on folders
  • complete wipe of the Mac and restored from Back up.

Each of these has worked in the short term [from a day or two, to a month]! then either the process stopped working when the error recurred [change temp folder location/permissions], or I have gotten annoyed with the error recurring because it seems like it is not a long term fix [reinstall MacOs/ wipe etc]. It’s been very frustrating. It’s been happening since the Catalina update.

Today I think it might have something to do with the temp folder. I use Audacity a LOT, and it does seems to work for a little while after I try some of the fixes. Like I’m reloading the folder to almost full each time, so it takes a little time to Refill. But I check the temp folder and it is empty. But as you can probably tell I’m flying blind here.

Also, when I get the error some other stuff happens with the Mac. If I try to download something, it constantly interrupts, citing unrecognised errors. And other Temp File-ey programs stop working properly too, which is why I’m lead to my Temp file suspicion.

I don’t know if this is where I should be writing all this, but I’ll cut and paste it somewhere.

I hope you can help. I’ve tried Apple support [where I got the instructions to do a lot of my attempted solutions] but they are all out of ideas and are recommending and suggested I look into the app, which is why I’m here.

I look forward to hearing from you.

I’ve got the same problem with Audacity 3.0.4 as 3.0.3. I didn’t have it until I upgraded from Audacity 2.4. In addition to attempted saves to my hard drive, I have tried saving to an external hard drive that has 2.7TB remaining capacity. I still get the message ‘Audacity failed to write file…perhaps disk is full or not writeable etc’. Here is the error report:

timestamp": 1631274836,
“event_id”: “c0a81382c4bb47febe47f4617e9de67a”,
“platform”: “native”,
“release”: “audacity@3.0.4”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Macintosh”,
“version”: “10.16.0”
“exception”: {
“values”: [
“type”: “Error_Writing_to_File”,
“value”: “Audacity failed to write file /.\nPerhaps disk is full or not writable.\nFor tips on freeing up space, click the help button.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false

I have checked my Library folder and can see that the 4.13 GB temporary file is there unsaved. Can anyone provide advice please? It looks like previous questions about this have never really been resolved.

If you care to zip up your .aup3 project file and upload it to a file sharing service, I’ll take a look at it. Post or PM me a link.

Thanks for your reply. When I was wondering whether or not it would be possible to zip up a temp file to send to you (given that I could not save the project), I decided to try to save again to the external hard drive. I discovered that I had been trying to save to a protected partition. When I changed to a different partition, saving a project and export of an mp3 has been successful. This still doesn’t explain why Audacity won’t save to my internal hard drive. It suggests that Audacity is not compatible with my hard drive’s set-up in some way. Something has changed in Audacity between 2.4 and 3.0.3/4

I’m glad you got this sorted. :smiley:

If you do Edit > Preferences > Directories, you can see the directories that Audacity tries to use for differing functions. Be sure that you have write access to each of these directories. BTW, “AppData” is a hidden directory.