FFmpeg with Audacity 2.3.2

Installing and updating Audacity on Windows#Installing the FFmpeg Import/Export Library on Windows says, “If you already have Audacity-compatible FFmpeg 2.2.x or 2.3.x shared libraries in the system PATH, Audacity will use those as long as you do not install FFmpeg from the links below and as long as you do not specify the FFmpeg you want Audacity to use in Libraries Preferences.”

I have so far not gotten this to work. I have “ffmpeg version N-89674 … Built w gcc 7.2.0” installed on a Windows 7 computer and “ffmpeg version N-93298 … Built w gcc 8.2.1” installed on a different machine running Windows 10. When I try to File > Open a *.MOV file, both say, “Audacity did not recognize the type of file ‘…MOV’. Try installing FFmpeg.” The PATH on both machines includes ~“ffmpeg/bin”.

https://lame.buanzo.org/#lamewindl says, “The Audacity(r) QA Team suggests users download the ZIP version”, clicking on “libmp3lame-win-3.99.3.zip”. Move that into a desired permanent location and unzip it by : “Extract All…”, confirm that the target directory is appropriate, and click “Extract”.

The instructions then said to open Audacity Library Preferences and FFmpeg Library “Locate”. I then got, “Audacity needs the file ‘avformat-55.dll’”. The extract folder did not contain that but instead contained “lame_enc.dll”. I entered that name and selected it and said, “OK”. This gave me, “A debugging check in this application has failed.”

What do you suggest?

Thanks, Spencerg

Download [u]ffmpeg-win-2.2.2.exe[/u]. Run that EXE file to install FFmpeg and you should be ready-to-go!

…but instead contained “lame_enc.dll”.

LAME is NOT FFmpeg. It’s ONLY for EXPORTING to MP3 and it’s now built-into Audacity so you don’t have to add it.

Great. Thanks. I got trapped by the claims “https://lame.buanzo.org/#lamewindl” that say, “The Audacity(r) QA Team suggests users download the ZIP version”.

Secondly, thanks for explaining LAME. I included that in instructions I’m publishing on Wikiversity at “https://en.wikiversity.org/wiki/Grassroots_media_training/KKFI/Audacity”. I need to delete the part on installing LAME.

Thanks again, Spencerg.

Can you suggest a debug procedure to follow with a defective install, especially of FFmpeg 2.2.2 for Audacity 2.3.2 under Windows 10?

I successfully installed FFmpeg 2.2.2 under Windows 7 and 10 plus macOS 10.14.6, but a friend tried to follow apparently the same procedure on Windows 10, and was unable to “open” or “import” a *.MOV file. I believe she followed the procedure on “https://manual.audacityteam.org/man/installing_and_updating_audacity_on_windows.html#winff”. She downloaded and ran ffmpeg-win-2.2.2.exe from, I think, “https://manual.audacityteam.org/man/installing_and_updating_audacity_on_windows.html#winff”. However, when she tried to read or import a *.MOV file, she got an error message saying she needed to have “C:\Program Files (x86)\FFmpeg for Audacity\avdevices-55.dll” and Audacity couldn’t find it, even thought it was on that computer AND Edit > Preferences: Libraries > “FFmpeg Library: Locate” = the location on my hard drive of avdevices-55.dll, which it said it needed. (Please excuse: I’m writing this from memory, because I do not have her computer in front of me.)

** I just noticed that on all three successful installs that I have, “Audacity > Preferences: Libraries: FFmpeg Library: Locate …” Audacity has automatically detected valid FFmpeg libraries." However on the Windows 10 Home computer with the defective install, “Audacity > Preferences: Libraries: FFmpeg Library: Locate …” points to “C:\Program Files (x86)\FFmpeg for Audacity\avdevices-55.dll”.

What do you suggest?

Thanks, Spencer Graves