FFmpeg not found

Hi all…

I’m using Audacity 2.2.0 on OS X Sierra, and have download the .zip file for ffmpeg at below link

I have located LAME, but FFMpeg is not found… I point to the file libavcodec.55.dylib, but audacity is not accepting it.

If there anything more i can do ? I have tried closing/reopening… copying libavcodec.55 to a folder on its own just to isolate the problem, but its still not picking it up.

I downloaded the .zip from here: http://lame.buanzo.org/#lameosxdl

and i downloaded the Binary ffmpeg-mac-2.2.2.zip

After you have un-zipped the FFmpeg archive, the best place to put it is:

/Library/Application Support/Audacity/libs

This is the same folder where the LAME installer puts the LAME files. You must put all the FFmpeg files there, not just libavcodec.55.dylib.

Note that this is not your user Library folder, but the system Library folder. You can get to this folder using the menu Go > Go to Folder, or by opening a Finder window on your startup disk, then opening the “Library” folder you see there. Once you have the FFmpeg files in that folder, Audacity should find them automatically.

– Bill


Perhaps i must use installer?

There is no audacity in /library/Application Support… All Application support files for apps the user installs is in your user folder:
/Library/Application Support/audacity/libs.

or Click “Go”, hold down Option, and select “Library”
Screen Shot 2017-12-06 at 4.20.06 am.png

Yes, that key combination reveals the user Library folder.

Yes, try the FFmpeg installer on that same page.

– Bill

I found out installer FFMpeg dmg created audacity/libs in root.

When i manually created these and copied files there Audacity detected… No problem.

I’m using Mac OS High Sierra 10.13.6 and Audacity 2.1.0
I’ve tried to download ffmpeg libraries in various ways, following all available instructions on the Audacity pages, but my Audacity still doesn’t find them. I’ve even tried the “Alternative zip download for expert users”, but rather than the three files I was told to expect, I just got a single file called “libmp3lame64bit.dylib” which I can only open on terminal. I’ve been trying to sort this out for quite a while. Any help would be appreciated!

First, Audacity 2.1.0 is very old. The latest version is 2.3.1. We recommend upgrading.

Second, you have downloaded the LAME file, not the FFmpeg file.

Third, you have downloaded the 64-bit LAME library. The 64-bit FFmpeg and LAME libraries are for use only with Audacity 2.3.1 and later.

Fourth, you do not “open” the dylib file. You drag it to the “libs” folder (an alias of which should be in the DMG window).

Fifth, on the website where you get FFmpeg, there is a PKG file and a DMG file. Download and run the PKG file - this will automatically install the 64-bit FFmpeg in the correct folder.

If you insist on continuing to run 2.1.0, scroll down on the website to the 32-bit installers and download the FFmpeg DMG, which contains a PKG installer that you can run.

– Bill