FFmpeg not found V3.0.3, 3.0.5 [SOLVED]

Hullo. I now have a need for FFmpeg to import mp4 for audio extraction and editing. Using current WIN10 Pro 64 bit.

Using V3.0.3:
I used the FFmpeg installer to install the ‘FFmpeg For Audacity’ folder and files.
I used Edit\Preferences to browse to Locate the folder, installed in the C:\Program Files folder.
I restarted the computer.
I attempted to load an mp4 but the ‘FFmpeg not found’ popup message appeared.
I relocated the ‘FFmpeg For Audacity’ folder and files under the ‘Audacity’ folder and re ‘Located’ the FFmpeg to the new location.
Again got the ‘FFmpeg not found’ popup message.
Tried changing permissions but no success.

Installed V3.0.5 and started it:
I successfully imported an mp4 played it and saved the project, using the FFmpeg in the above location.
Then closed and reopened Audacity, attempted to import the mp4 but got the ‘FFmpeg not found’ popup message.
I restarted the computer but got the same fail condition.
I re installed the FFmpeg, ‘Located’ it Edit to the original directory location, restarted the computer but still got the error message.
I did a reinstall of V3.0.5 and again it worked correctly until closing & opening it again

Can someone please suggest a solution?

It seems a bit ‘over the top’ to have to reinstall each time I need to use FFmpeg. :slight_smile:

Jut one thing I can think of…

If you’re running the 64-bit version of Audacity, the installer is FFmpeg_v2.2.2_for_Audacity_on_Windows_64bit.exe and when you run the installer FFmpeg should get installed to C:\Program Files\FFmpeg for Audacity.

The installer for the 32-bit version is ffmpeg-win-2.2.2.exe and it should be installed to C:\Program Files (x86)\FFmpeg for Audacity.

Thanks for your reply DVDdoug.

I was using 64 bit V3.0.3 and am using 64 bit V3.0.5 and the 64 bit FFmpeg did install as you describe. I have also used the ‘Locate’ function in the ‘EDIT’ menu to tell Audacity the correct folder address.

As noted in my first post it works once automatically immediately after installation then is unable to use the FFmpeg folder.

I can’t see where anything is wrong.

I had the same problem : Audacity 3.0.5 wants an old FFMPEG version that I couldn’t find on ffmpeg.org.

But I have VS2019 on my computer and I compiled the latest version on github …

This release detects and works with ffmpeg-n4.4-152.

Audacity 3.0.5 wants an old FFmpeg that is built for Audacity and is available from the link provided in the Audacity manual: Installing FFmpeg for Windows - Audacity Manual

The FFmpeg version for Audacity is likely to be updated soon (the developers have been updating it).

Thank you for replying lg29 and steve.

lg29, I may have to look into what you said. I was a developer on IBM AS400s many years ago but haven’t done any programming for a long time.

steve, the version of FFmpeg linked from the link to the manual you posted is the same version I had already attempted to use.

It works once after a reinstall of Audacity but after closing and starting it shows the message popup - ‘FFmpeg startup failed’ containing msg ‘FFmpeg was configured in Preferences and successfully lade before, but this time Audacity failed to load it at startup. You may want to go back to Preferences > Libraries and reconfigure it’.

In Preferences > Libraries it is still shown as correctly addressed.

It sounds like there has been a mix up of incompatible versions somehow. If we can figure out what the mix-up is, then it should be fairly simple to resolve the problem.

What was the earliest version of Audacity that you have had installed on that computer?
How many versions of Audacity do you currently have installed?
How many versions of FFmpeg have you installed (ever) on that computer?

What exactly do you see in " Preferences > Libraries"?

Just to cover bases; You are using Windows 10 only?

The laptop was bought in February 2020 so the oldest version of Audacity would have been the current one then. I have not had FFmpeg popups before I recently needed to import an mp4 once a week and have only tried to do this since having V3.0.3 and V3.0.5. I replaced the initial version in August after setting up a laptop at my church (where I’m the sound guy) and seeing the new generation with just the one project object. The mp4 is generated by OBS which is used to combine cameras and audio to feed Zoom.

This is what I have copied/pasted from Preferences\Libraries C:\Program Files\FFmpeg For Audacity\avformat-55.dll

After first having the problem I changed the address of the FFmpeg folder so that the new ones installed (as shown above) as per various suggestions earlier in this thread.

The laptop, a Dell Vostro15 3000, runs win 10 pro as installed by Dell. No other OS has been near it (I have an older desktop for doing that with).

As described earlier in the thread the reinstalling still gives me a one-time go work around.

Look in \Program Files
Do you see one or more “Audacity” folders there?
Do you see one or more “FFmpeg” folders there? (names may “FFmpeg for Audacity”, or “ffmpegyag” or “ffmpeg-2.2.2-win32-shared” or similar)

Look in \Program Files (x86)
Do you see one or more “Audacity” folders there?
Do you see one or more “FFmpeg” folders there?

Thanks steve.

As previously above there was one ‘Audacity’ folder and the recently added ‘FFmpeg for Audacity’ folder in ‘Program Files’.

I found another ‘Audacity’ folder in ‘Program Files x86’ dated in Feb 2020. A mouse-over on the executable showed as V3.0.2 from July 2021. So I had apparently updated without running the uninstall. There was no folder with any FFmpeg related name.

I ran the V3.0.2 uninstall.exe and removed the ‘Audacity’ folder from ‘Program Files x86’, and deleted the related shortcut.

I created a new shortcut from the audacity.exe V3.0.5 in the ‘Program Files’ folder. It now correctly imports mp4 files. GREAT!

Thank you again.

Super :slight_smile: Thanks for the update.
I’ll close this topic as “solved”.