FFmpeg Library not found - Audacity 2.1.0 [SOLVED]

I updated to Audacity 2.1.0. Preferences says FFmpeg library not found. Clicking Locate… it appeared right away. I clicked OK, but looking again it says not found. What’s happening?

If you updated from Audacity 2.0.5 or earlier, you need a new FFmpeg 2.2.2 version, as it says at the top of the Release Notes 2.1.0.

Download FFmpeg from this page http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#ffdown.


Thanks. I see the latest FFmpeg is 2.6.1. Is that not recommended?

As it says on http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#ffdown, FFmpeg 2.4.x and later is not supported except for command-line export using the (external program) choice.

This means that if you want to import files into Audacity that require FFmpeg, you must use the FFmpeg 2.2.2 installer we recommend, or if you find a suitable FFmpeg 2.3.x set of shared libraries such as from Zeranoe, you can use those instead.

If you are only interested in exporting to FFmpeg audio formats, and you are prepared to use command-line export, then you can use any later FFmpeg library that includes “ffmpeg.exe”, pointing the Audacity command to that exe. See Exporting to an external program for details.


I tried to save the download to C:Program Files (x86)FFmpeg for Audacity, but it says I don’t have permission, consult the administrator. How can I do this?

As with any installer, log in as administrator, or right-click over the installer, choose “Run as administrator” and provide the password.

If your administrator forbids you to install, obtain the ZIP version of FFmpeg 2.2.2, extract it to a location where you have permission, then use the Libraries Preferences in Audacity to browse to and open avformat-55.dll. See http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#locate.


I got it as far as the avformat-55.dll appearing in the space when I clicked Locate in library Preferences. Then I clicked OK, but when I looked again, it was still “not found”. I cannot import mpeg.

If the next instruction is successful, and it is found, and I can import, do I need to leave the dll where I put it?

Make sure you got FFmpeg 2.2.2 from http://lame.buanzo.org/#lamewindl if you wish to import video files.

If Libraries Preference says “not found” you cannot import files using FFmpeg. Note that you need all the shared FFmpeg files in the download to be present alongside avformat-55.dll when you select it.

No you cannot move the files unless you go through the “Locate” process again.

If Audacity does not see avformat-55.dll after checking the download and that you extracted all the files, please attach the contents of Help > Show Log… top right of the Audacity menus. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1


Thanks, I finally got it, and learned a few things.