FFmpeg just not working...

I’ve read every thread I can find on this topic, tried every potential solution, but the FFmpeg library is “not found” regardless of what I do.

Audacity 3.0.2 installed (and reinstalled after installing FFmpeg package)
FFmpeg 2.2.2 installed

Both program file sets installed in /Program Files (x86)

When browsing for the FFmpeg file from audacity, it sees it, recognises it, but then when I lclick “ok” it just persists in saying FFmpeg Library Not Found.

Maybe I’m missing something obvious by misreading something or I’ve got my version compatability mixed? But I just can’t get this to work.
Please help.

…Just making sure - Did you actually “install” it by RUNNING ffmpeg-win-2.2.2.exe?

Both program file sets installed in /Program Files (x86)

There should be a sub-folder called FFmpeg For Audacity and in that folder you should several files including avcodec-55.dll.

That’s just it though, I have it correctly downloaded it, multiple times even! Audacity even automatically registered the FFMPEG but when I link them together it still tells me I need an FFMPEG when I try to put the video with its multiple audio sources in it! I’ve scoured the internet for an answer to this problem and the only response I get is “well did you download it?” YEs! I did! It’s just not working. I’ve spent hours troubleshooting and searching and I’m exhausted. If you have an answer that is not “download the FFMPEG” as to how I can fix having everything and it still not working then it would be greatly appreciated.