FFMPEG installed, Audacity cannot import m4a [SOLVED]

Hi everybody,
I know this is a FAQ but I have got some problems because it should work. I’m using CentOS 7 and I compiled from source code audacity-minsrc-2.1.1 after compiled the ffmpeg library version 2.3.6 (it should be a compatible version) using --enable-shared so i have the libavformat.so file. I have positioned a symbolic link in /usr/share/pkgconfig pointing to /usr/local/lib/pkgconfig for the pc files before install audacity as well. But Audacity still not import m4a files also if i go to preferences and manually set the path for libavformat.so.
What is the problem?

What “pc files” are those? There is no need for that step, as far as I know, unless it is something that CentOS requires you to do.

Do you see the F,C,U numbers in Libraries Preferences? If yes, the problem is with the M4A files - look at Help > Show Log… .

Have you tried configuring Audacity with --disable-dynamic-loading, which removes the Libraries Preferences?


PC files concern pkg-config. I prefer to leave default setting when config make ecc and so pkg-config often does not find installed libraries because it look for them in /usr/share/pkgconfig instead of /usr/local/lib/pkgconfig where often are installed. Making a symbolic link it works.

I cannot see F, C, U numbers… i’ve got “FFMpeg library not found”… Here’s the log (it’s in italian but definitely there’s written Error: impossible to open compatible FFMpeg libraries"

“14:15:55: Loading avformat from ‘libavformat.so.55’.
14:15:55: Errore: libavformat.so.55: impossibile aprire il file oggetto condiviso: File o directory non esistente
14:15:55: Errore: Failed to load FFmpeg libraries.
14:15:55: Errore: Impossibile trovare librerie FFmpeg compatibili.”

I’ll try to configure it with --disable-dynamic-loading!

As a double-check,

pkg-config --libs libavcodec

should confirm what FFmpeg libs pkg-config will find.


I’m sorry yesterday i thought i had answered… Now It Works! Many many many thanks! I configured audacity with --disable-dynamic-loading and then it worked… (I had to create symbolic link for library because they were in /usr/local/… instead of /usr/lib and audacity could not find them but it’s normal…) Thanks!