FFmpeg installed and located but not useable

I have successfully imported video files (from OBS) to Audacity to take the sound and convert to audio files. But this function has stopped working. I don’t remember if I used the .mkv file or the remuxed .mp4 file, but I have tried it with both. I have attached a compilation of all the error messages, the files I have installed, and the location/path according to my file explorer.

I have tried to use both file-> open and file-> import and had no success; I’ve done this before to export .mp3 and .wav files of my D&D games, but I can’t remember how, or if something is truly not working right.

Audacity version 3.0.0
Windows 10 Home

To test if FFmpeg is working in Audacity, try “Exporting” some audio from Audacity as “M4A” (or “AAC”).
“File menu > Export > Export Audio” then select “M4A” as the file type.

If you are able to export as M4A and AAC, then FFmpeg is working and the problem is that FFmpeg can’t open those files for some reason.

Yes, I could export as .m4a just fine, and I could hear/play the audio track with windows’ player app just fine after, as well. So what do I do about FFmpeg not being able to access those files right? Is there another source for them I could use? I realize this is an audacity forum, not an FFmpeg forum, I’m just not very computer literate.

I’d suggest looking into OBS to see what export options are available. Probably a good idea to test with a short recording so that testing is quicker, and when you find settings that work, write them down and try the same settings with your real recordings.

Thank you, I’ll see what I can find. What’s frustrating is that, it worked last month. Now it doesn’t.