[Fedora23] audacity hang when startup

After upgrade to audacity-freeeword ( but the same happened to standard audacity ) the program start and freeze when I start it on my ususal account.

Name : audacity-freeworld
Arch : i686
Epoch : 0
Version : 2.1.2
Release : 1.fc23
Size : 19 M

The program start well if call audacity from root.
belowe I will show a sample of the warnings.
I suspect that there was some worng configuration in my home but I didn’t know where look for it.
Someone have some suggestions ?

Thanks in advance,

[enzo@enzo7 ~]$ audacity

(Audacity:10829): GLib-GObject-WARNING **: cannot register existing type ‘GdkDisplayManager’

(Audacity:10829): GLib-CRITICAL **: g_once_init_leave: assertion ‘result != 0’ failed

(Audacity:10829): GLib-GObject-CRITICAL **: g_object_new: assertion ‘G_TYPE_IS_OBJECT (object_type)’ failed

(Audacity:10829): Gnome-WARNING **: Accessibility: failed to find module ‘libgail-gnome’ which is needed to make this application accessible

(Audacity:10829): GLib-GObject-WARNING **: cannot register existing type ‘GtkWidget’

(Audacity:10829): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion ‘G_TYPE_IS_INSTANTIATABLE (instance_type)’ failed

(Audacity:10829): GLib-GObject-WARNING **: cannot register existing type ‘GtkBuildable’

(Audacity:10829): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion ‘G_TYPE_IS_INTERFACE (interface_type)’ failed

(Audacity:10829): GLib-CRITICAL **: g_once_init_leave: assertion ‘result != 0’ failed

(Audacity:10829): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion ‘G_TYPE_IS_INSTANTIATABLE (instance_type)’ failed

(Audacity:10829): GLib-GObject-CRITICAL **: g_type_register_static: assertion ‘parent_type > 0’ failed

There may be problems with the Fedora packages of Audacity. If you tried the 2.1.1 Fedora package, it is necessary to downgrade soundtouch in order to launch Audacity: http://forums.fedoraforum.org/showthread.php?t=308943.

When Audacity would not launch, did you see an error dialogue about Audacity not being able to find anywhere to write its Preferences? If so, follow that dialogue.

Your console errors look “normal”.

If it’s a Fedora packaging problem in 2.1.2 also, you can raise a bug report with Fedora or compile Audacity yourself. This topic may be useful to you: https://forum.audacityteam.org/t/fedora-23-audacity-2-1-2-crashes-on-startup/41796/1


using the strace utility I get the following

3 [enzo@enzo7 ~]$ strace /usr/bin/audacity
5 execve(“/usr/bin/audacity”, [“/usr/bin/audacity”], [/* 64 vars */]) = 0
6 brk(NULL) = 0x81b90000
7 mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb774c000
8 access(“/etc/ld.so.preload”, R_OK) = -1 ENOENT (No such file or directory)
9 open(“/etc/ld.so.cache”, O_RDONLY|O_CLOEXEC) = 3
10 fstat64(3, {st_mode=S_IFREG|0644, st_size=251594, …}) = 0
11 mmap2(NULL, 251594, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb770e000

2730 mprotect(0xacecd000, 4096, PROT_READ) = 0
2731 futex(0xb4850940, FUTEX_WAKE_PRIVATE, 2147483647) = 0
2732 futex(0xb4850940, FUTEX_WAKE_PRIVATE, 2147483647) = 0
2733 futex(0xb4850940, FUTEX_WAKE_PRIVATE, 2147483647) = 0
2734 futex(0xb4850940, FUTEX_WAKE_PRIVATE, 2147483647) = 0
2735 futex(0xb4850940, FUTEX_WAKE_PRIVATE, 2147483647) = 0
2736 write(2, “\n(Audacity:13423): GLib-GObject-”…, 86
2737 (Audacity:13423): GLib-GObject-WARNING **: cannot register existing type ‘GtkWidget’
2738 ) = 86
2739 write(2, “\n(Audacity:13423): GLib-GObject-”…, 134
2740 (Audacity:13423): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion ‘G_TYPE_IS_INSTANTIATABLE (instan ce_type)’ failed
2741 ) = 134
2742 write(2, “\n(Audacity:13423): GLib-GObject-”…, 89
2743 (Audacity:13423): GLib-GObject-WARNING **: cannot register existing type ‘GtkBuildable’
2744 ) = 89
2745 write(2, “\n(Audacity:13423): GLib-GObject-”…, 136
2746 (Audacity:13423): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion ‘G_TYPE_IS_INTERFACE (inter face_type)’ failed
2747 ) = 136
2748 write(2, “\n(Audacity:13423): GLib-CRITICAL”…, 87
2749 (Audacity:13423): GLib-CRITICAL **: g_once_init_leave: assertion ‘result != 0’ failed
2750 ) = 87
2751 write(2, “\n(Audacity:13423): GLib-GObject-”…, 134
2752 (Audacity:13423): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS

Please see my previous post. Audacity is not responsible for Fedora packaging errors.

However you can probably run the 2.1.1 package without running as root by downgrading soundtouch.


Sorry Andrews, i didn’t saw your post before.

Yes, I known the bugs related to soundtrack and I got these problem some weeks ago and I solved using downgrade.
Now downgrade cause the audacity to crash, so what I think is that now both program and packaging are correct but I should have some old configuration data that cause the problem.
In my case, actually, audacity don’t crash.
It just simply don’t show some windows but the program it still running.

If then I create an user from scratch an I run audacity , it run politely.
So I think is a problem related to some old config or old cache in my home.

So I have tried to remove some cache and some config in my home but I have non success and I want to avoid to delete all my working home so I will ask support to know what files ( both config and cache and others ) are related with audacity in order to remove it from my home.
I Hope you can help me.

Regards, enzo

Which Audacity package crashes? Your previous posts were about audacity-freeworld 2.1.2 and I thought you were saying you could run that as root.

Uninstall all Audacity packages. Then install the package you do want to use.

Force quit Audacity in your task manager application.

Open the file ~/.audacity-data/audacity.cfg. In that file, note the path to your Audacity temporary folder. It’s at TempDir= underneath the [Directories] line.

Close and delete that audacity.cfg file.

Navigate to the TempDir folder that you noted in the audacity.cfg file. In that folder, delete any audacity-lock- file that you see.

If root owns the Audacity executable, log in as root and change ownership to your user.


well , I do all these whitout success

I’ll resume my attempt.
I have my account ‘enzo’ with all my data and here audacity start and hang without open the program windows.
I create an empty account from scratch named ‘test2’ , and here audacity start politely.

I delete .audacity-data from the account enzo.
I start audacity and the .audacity-data is NOT created.
This suggest me that audacity hangs somewhere before accessing that directory.

So I copy the .audacity-data from account ‘test2’ to ‘enzo’ and I changed the file audacity.cfg on ‘enzo’ to appropriate directories

account test2

[test2@enzo7 ~]$ grep test2 .audacity-data/audacity.cfg

account enzo

[enzo@enzo7 ~]$ grep enzo .audacity-data/audacity.cfg

I compared the two directories and the related files:

when audacity start on test2 the tempDir show the lock files

[root@enzo7 ~]# find /var/tmp/audacity-test2

while when I start audacity on account ‘enzo’ non lock files was created

[root@enzo7 ~]# find /var/tmp/audacity-enzo

So I think that there should be some parameter that audacity will check before create or read the directory .audacity-data

Which Audacity version are you using now?

Use the account that you used to install Audacity, or uninstall it then reinstall it with the account you want to use. If necessary change the ownership of the Audacity executable to the account you want to use.

Or, before launching Audacity, set TempDir in audacity.cfg to a location your user has permission to write to.

If you are using Audacity 2.1.1, you may want to use or compile 2.1.2.

2.1.2 should handle lock files better due to the upgrade to wxWidgets 3, and should have better user facing dialogues when there are issues writing files necessary for launch.


well, at the end I solved recreating my user.

As said in a previous post , on a new user audacity wroked, so I recreate my home user from scratch and I solved.
Thanks for the help.


I found the solution:
Gnome2 accessibility is enabled and this requires libgail-gnome which is not available anymore :frowning:
This occurs even if audacity is compiled with wxGTK3.

To disable gnome2 accessibility, use the command:

gconftool-2 --set /desktop/gnome/interface/accessibility --type bool false

After that, audacity starts properly again :smiley:

Thanks for posting.

So if you run that command, even the Fedora-packaged version of Audacity launches, and so it is a packaging problem?

The current Audacity 2.1.2 source code requires wxGTK 3.0.x, preferably 3.0.2. If you compile wxWidgets yourself it should be built with the default gtk2 option, not with gtk3.


Thanks for this thread! I have/had the same issue on Xubuntu 19.10 and Audacity 2.3.2.

Did this (very old) thread allow you to resolve the issue? If so, what exactly did you do to fix the problem?