Fedora 31 - How to record from speakers/software


Information of the OS and computer - Acer Aspire 3 “A315-53-P8QX” ; inxi -Fxmz

  Kernel: 5.8.18-100.fc31.x86_64 x86_64 bits: 64 compiler: gcc 
  v: 2.32-33.fc31) Desktop: Cinnamon 4.4.8 
  Distro: Fedora release 31 (Thirty One) 
  Type: Laptop System: Acer product: Aspire A315-53 v: V2.02 
  serial: <filter> 
  Mobo: KBL model: Metapod_KL v: V2.02 serial: <filter> 
  UEFI [Legacy]: Insyde v: 2.02 date: 01/03/2019 
  ID-1: BAT1 charge: 27.1 Wh condition: 27.1/36.7 Wh (74%) 
  model: COMPAL 0038314234314341 status: Full 
  RAM: total: 7.65 GiB used: 2.01 GiB (26.3%) 
  Array-1: capacity: 32 GiB slots: 2 EC: None max module size: 16 GiB 
  note: est. 
  Device-1: ChannelA-DIMM0 size: 4 GiB speed: 2400 MT/s type: DDR4 
  Device-2: ChannelB-DIMM0 size: 4 GiB speed: 2400 MT/s type: DDR4 
  Info: Dual Core model: Intel Pentium 4417U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18399 
  Speed: 800 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
  Device-1: Intel vendor: Acer Incorporated ALI driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: Quanta VGA WebCam type: USB driver: uvcvideo bus ID: 1-7:5 
  Display: server: Fedora Project X.org 1.20.6 driver: modesetting 
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 610 (Kaby Lake GT1) 
  v: 4.5 Mesa 19.2.8 direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Device-2: Logitech G35 Headset type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-3.1:4 
  Sound Server: ALSA v: k5.8.18-100.fc31.x86_64 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus ID: 01:00.1 
  IF: enp1s0f1 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 3000 bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
  IF-ID-1: virbr0 state: down mac: <filter> 
  IF-ID-2: virbr0-nic state: down mac: <filter> 
  Local Storage: total: 238.47 GiB used: 29.75 GiB (12.5%) 
  ID-1: /dev/sda vendor: SK Hynix model: HFS256G39TND-N210A size: 238.47 GiB 
  temp: 35 C 
  ID-1: / size: 68.39 GiB used: 23.59 GiB (34.5%) fs: ext4 dev: /dev/dm-1 
  ID-2: /boot size: 975.9 MiB used: 271.0 MiB (27.8%) fs: ext4 
  dev: /dev/sda1 
  ID-3: /home size: 156.18 GiB used: 5.90 GiB (3.8%) fs: ext4 dev: /dev/dm-3 
  ID-1: swap-1 type: partition size: 7.78 GiB used: 0 KiB (0.0%) 
  dev: /dev/dm-2 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 242 Uptime: 12m Init: systemd runlevel: 5 Compilers: gcc: 9.3.1 
  Packages: 2463 Shell: Bash v: 5.0.17 inxi: 3.1.08

Audacity 2.4.2 - Flatpak install

Trying to record some sound (from Firefox/Youtube), but Audacity doesn’t pick up any sound (forever silence). I tried to select different record sources from within Audacity, but to no avail.

Tried this guide on youtube, but the “Volume Control” application doesn’t match the “Sound” app included in Fedora in such a way that makes it possible to use that guide.

I have made a forum thread on the Fedora user forum where provided a workaround for getting sound files from youtube and other sites, But I still wonder if this is possible to achieve without other software that Audacity itself.

Thanks in advance

That seems to be based on the Audacity documentation: https://manual.audacityteam.org/man/tutorial_recording_computer_playback_on_linux.html

The “Volume Control” app that you need is “PulseAudio Volume Control” (pavucontrol).