Failed to import mp4 through FFMPEG

I’ve done a clean install of a PC and cannot get Audacity (v2.0.3) to import m4a files, despite having FFMPEG installed.

The log says

21:22:04: File name is /home/peter/test-file.m4a
21:22:04: Mime type is *
21:22:04: Opening with libav
21:22:04: Error: FFmpeg : av_find_stream_info() failed for file /home/peter/test-file.m4a
21:22:04: Opening with libsndfile
21:22:04: Opening with liboggvorbis
21:22:04: Opening with libflac
21:22:04: Opening with lof
21:22:04: Error: Importer::Import: Opening failed.

I cannot find anything substantive googling this particular error. Have re-installed FFMPEG, just for fun…

Any thoughts?

Where did the m4a come from and what assurances do you have that it is a valid m4a?


A good question - I don’t have any assurances.
So I put the previous hard drive back into the laptop - Ubuntu 12.04 with Audacity 2.0.0 - and successfully opened, edited and exported to MP3 that same file.

The clean install is running SolydK. Both Debian based Linux. I’m assuming that there is a config somewhere that I need to tweak…

Now you need one of the linux elves. I’m out. Koz

It looks as if the build of FFmpeg on your SolydK machine does not support m4a.
Some distributions do not include support for restricted formats by default. You may need to enable an additional repository to get software that supports restricted format, and then re-install FFmpeg, or you may need to build FFmpeg from the source code.

To check if m4a is supported by FFmpeg, open a Terminal window and enter:

ffmpeg -formats

This will print out a list of supported formats. Look to see if “mp4” and “aac” are in the list.

Thanks of that - you’ve hit the problem. m4a on this install only supports encoding (interestingly aac is only supported for decoding). Now I know where my problem is.

Thanks for the support