External microphone is not available

Audacity 2.1.0
OSX El Cap

I have an external microphone, but it is not selectable. Please see attached images.
Screen Shot 2016-05-05 at 3.16.27 PM.png
Screen Shot 2016-05-05 at 3.16.55 PM.png

I’m lost. The Cam Chat is available, but you can’t click on it?

Audacity may not see a connection if it’s established after Audacity starts, you can just restart Audacity to make it appear. But it looks to me like it’s there.



Some devices that don’t say “Microphone” in the title need special drivers or software to work. Cam Chat is a video communications device, not a microphone.


Cam chat is the mic on the webcam. I have a directional microphone device that is plugged into the headphone jack. That’s the one I want to use to record, not the Cam Chat mic.

First I’ve run into this where the Mac knows the analog connection is there, but not Audacity. What’s the machine? Built-In Microphone usually means an MBP or maybe an Macbook Air. iMacs have built-ins.

Has this ever worked?

The Mac plays games to get everything jammed into that one connection. If the Mac doesn’t make the microphone available as a standard audio device to the rest of the machine, Audacity is not going to see it. It’s also possible you have the wrong adapter and the Mac is making incorrect assumptions as to what you plugged in.

My Macs give me a sound meter in the System Preferences. Does yours and does it work? While you have the microphone plugged in, see what turns up in Go > Utilities > Audio MIDI Setup.

Another place to see what’s going on is Apple (upper left) > About This Mac > More Info > System Report > Audio.

Do restart Audacity with everything connected. Audacity checks for New Devices and Connections when it starts.


Make and model number of this microphone device? Model number of the Mac?

If your Mac only has a headphones port, then the only input it is going to accept there is an Apple headset with mic, or some other mic with a TRRS four-position plug (or mic that is connected to a four-position TRRS adaptor).

Does GarageBand see this external microphone?


Thank you for your help!

Model Name: Mac mini
Model Identifier: Macmini7,1 (Late 2014)
Processor Name: Intel Core i5


Built-in Microphone:

Default Input Device: Yes
Input Channels: 2
Manufacturer: Apple Inc.
Current SampleRate: 44100
Transport: Built-in

Built-in Output:
Default Output Device: Yes
Default System Output Device: Yes
Manufacturer: Apple Inc.
Output Channels: 2
Current SampleRate: 44100
Transport: Built-in

Live! Cam Chat HD VF0790:
Input Channels: 2
Manufacturer: Creative Technology Ltd.
Current SampleRate: 48000
Transport: USB

Intel High Definition Audio:
Audio ID: 108
Connection: Combination Output
Connection: Internal
Line Input:
Connection: Combination Input
External Microphone / iPhone Headset:
Connection: Combination Output
S/PDIF Optical Digital Audio Output:
Connection: Combination Output
S/PDIF Optical Digital Audio Input:
Connection: Combination Input
HDMI / DisplayPort Output:
Connection: Display

The mic is actually part of a headphone set combo - It’s Hesh 2 Wireless HOWEVER it is plugged in and is not in bluetooth mode.

The mic is working on OSX:
Screen Shot 2016-05-06 at 10.46.30 AM.png

Good question, and yes. It sees it and it works.

See? That’s what I ran into. Conflicting symptoms.



I’m not sure how to interpret your last post. It works in GB, but not Audacity.
It seems like whatever list of sources Audacity generates is not complete.

I’m not sure how to interpret your last post.

We’re even. We’re not sure how to interpret your symptoms.

Other than this one. Your symptoms could be of one broken computer. Whenever someone arrives with a “Bug” or major deficiency in Audacity, it’s good to look around at all the other people having the same problem.

I think you’re the first one. There are two Mac Minis in the group and we could gear up and try to recreate the symptoms, but I don’t think anyone has a similar headset, and it would take us a while to duplicate the physical conditions.


Did you restart Audacity? It sees the built-in mic, which is not listed in your Sound Preferences. Does connecting a headset to the headphones output disable the built-in mic?