Exporting to ALAC


So I’ve been using Audacity for many years, and I’ve exported 1000+ files to ALAC (or MPEG-4/.m4a) by selecting “external program” in the export menu.

But after clean installing my Windows 10, I can’t get this to work again. I don’t remember how I got it to work last time.

I’m using Audacity version 3.3.3 and ffmpeg 6.0 full build downloaded from gyan.dev

This is what it looks like before trying to export:

But after hitting “Save”, I get the following error message:

“C:\Program Files\Audacity\ffmpeg-6.0-full_build-shared\bin\ffmpeg.exe” -i - -acodec alac “C:\Users\Magnus\Downloads\01 It’s a Long Way to the Top (If You Wanna Rock ‘n’ Roll).m4a”

ffmpeg version 6.0-full_build-www.gyan.dev Copyright (c) 2000-2023 the FFmpeg developers
built with gcc 12.2.0 (Rev10, Built by MSYS2 project)
configuration: --enable-gpl --enable-version3 --enable-shared --disable-w32threads --disable-autodetect --enable-fontconfig --enable-iconv --enable-gnutls --enable-libxml2 --enable-gmp --enable-bzlib --enable-lzma --enable-libsnappy --enable-zlib --enable-librist --enable-libsrt --enable-libssh --enable-libzmq --enable-avisynth --enable-libbluray --enable-libcaca --enable-sdl2 --enable-libaribb24 --enable-libdav1d --enable-libdavs2 --enable-libuavs3d --enable-libzvbi --enable-librav1e --enable-libsvtav1 --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs2 --enable-libxvid --enable-libaom --enable-libjxl --enable-libopenjpeg --enable-libvpx --enable-mediafoundation --enable-libass --enable-frei0r --enable-libfreetype --enable-libfribidi --enable-liblensfun --enable-libvidstab --enable-libvmaf --enable-libzimg --enable-amf --enable-cuda-llvm --enable-cuvid --enable-ffnvcodec --enable-nvdec --enable-nvenc --enable-d3d11va --enable-dxva2 --enable-libvpl --enable-libshaderc --enable-vulkan --enable-libplacebo --enable-opencl --enable-libcdio --enable-libgme --enable-libmodplug --enable-libopenmpt --enable-libopencore-amrwb --enable-libmp3lame --enable-libshine --enable-libtheora --enable-libtwolame --enable-libvo-amrwbenc --enable-libilbc --enable-libgsm --enable-libopencore-amrnb --enable-libopus --enable-libspeex --enable-libvorbis --enable-ladspa --enable-libbs2b --enable-libflite --enable-libmysofa --enable-librubberband --enable-libsoxr --enable-chromaprint
libavutil 58. 2.100 / 58. 2.100
libavcodec 60. 3.100 / 60. 3.100
libavformat 60. 3.100 / 60. 3.100
libavdevice 60. 1.100 / 60. 1.100
libavfilter 9. 3.100 / 9. 3.100
libswscale 7. 1.100 / 7. 1.100
libswresample 4. 10.100 / 4. 10.100
libpostproc 57. 1.100 / 57. 1.100
Guessed Channel Layout for Input Stream #0.0 : stereo
Input #0, wav, from ‘fd:’:
title : It’s a Long Way to the Top (If You Wanna Rock ‘n’ Roll)
album : 101 - High Voltage
date : 1976
track : 1
genre : Hard Rock
artist : AC/DC
Duration: N/A, bitrate: 2822 kb/s
Stream #0:0: Audio: pcm_f32le ([3][0][0][0] / 0x0003), 44100 Hz, 2 channels, flt, 2822 kb/s
[NULL @ 00000276ffc06ac0] Unable to find a suitable output format for ‘“C:\Users\Magnus\Downloads\01’
“C:\Users\Magnus\Downloads\01: Invalid argument

Does anyone know what’s wrong?
It means so much to me to solve this problem. I’m greatful for any help.

I don’t have any personal experience running FFMpeg stand-alone.

Speaking of which, have you tried running it from the command prompt ?

So I would probably start by asking at gyan.dev

If you look closely you have “smart” quotes (aka curly quotes) around the %f argument in the command line. Try changing those to straight quotes.

Thank you so much for your suggestions guys, but suddenly it all worked fine.
I have no idea what did it, but I might have forgotten to reboot my PC after having installed FFmpeg.

But thanks anyway. I really appreciate you for trying to help.

This topic was automatically closed after 30 days. New replies are no longer allowed.