exporting selected audio greyed out

I have a large mp3 file (540mb; 6 hours, 30 min) that I have been ripping into individual tracks. Everything seemed to be going fine. I was using the start and stop time blocks on the bottom, then would click the “export selected audio” and rename the file. I did about 30 tracks, then the “export selected audio” became greyed out. I have tried restarting the program, unselecting the track and then reselecting it, even saving the aup file, with no luck. Any suggestions? This happened after 21 tracks, then did it again after 10 more tracks. Very frustrating. Any suggestions would be greatly appreciated.

Which version of Audacity (look in “Help > About Audacity”). If not Audacity 2.1.3, please update: http://www.audacityteam.org/download/windows/

Yes, I am running 2.1.3

Ensure that playback is “stopped” and not “paused”.

Would “Export Multiple” be better than exporting one at a time? http://manual.audacityteam.org/man/export_multiple.html

Playback is stopped. I think exporting multiple would be better, but I don’t know how to do that (yet). I’m just a novice at this. I will look into it. But, that still doesn’t help me try to figure out why it stopped allowing me to export selected audio.

The only reasons that I can think of for “Exported Selected Audio” being greyed out are, either Audacity is in “pause” mode, or there is no selected audio.

I’m not sure why it was greyed out either because it was not in “pause” mode and the audio track was selected. I did a couple of things just now. I first deleted the project file (.aup), then deleted the data folder with the (.au) files in it. I then brought in the original large mp3 file and started ripping again. So far, I did complete the first group of files that I wanted to rip, which is about an hour long (36 tracks). I will continue with this project later on tonight to see if it continues to operate smoothly and without any glitches. I’m not really sure what the .au data folder was or is used for. If anyone can enlighten me, that would be great. Thanks.

The “_data” folder contains the “.au” files which are the “audio”. The “.aup” file tells Audacity how to fit the .au file together to create the “project”.
More information here: http://manual.audacityteam.org/man/audacity_projects.html

I do appreciate the info and suggestions on trying to figure out why Audacity is not performing properly on my PC. Unfortunately, it is happening much too frequently for me to continue to use this program for this project. I will continue to use Audacity for smaller projects in the future. Thanks for the support.

If you accidentally click in the grey background underneath the track, this deselects the track and would grey out Export Selected Audio even though there is still a time range. Pressing ENTER on your keyboard should reselect the track with its time range.


Discovered the same ‘bug’ here, v2.1.3 on Windows 10. Long-time user of Audacity to do some simpler things that now occasionally don’t work. Haven’t figured out what triggers it.

I imported multiple WAV files, generally a piano/accompaniment track plus many (6-10) vocal tracks. SOME times the option to Export Selected Audio is enabled, sometimes it isn’t.

This most recent project I was able to highlight three tracks and Export Selected Audio to an MP3 file as usual. I deleted the two vocal tracks I didn’t need anymore (with several still imported). I highlighted one of them and made sure “Export Selected Audio” was still active. I changed the levels on both tracks (to be louder, using the slider on the far left of each track), selected the three tracks I wanted, but Export Selected Audio was greyed out.

This has happened quite a few times today. My workaround (which kinda sucks) was to copy the tracks to a new project and Export Audio, but I lose my MP3 tags & such - highly annoying.

There are a few other changes from the last version (sorry, I don’t recall which) that I miss, but this one is a fairly obvious one. I don’t think I’m doing anything different to trigger the loss of the Export Selected Audio feature.

Anyone else experiencing this other than the OP? And me?

I don’t think it’s fair to call it a “bug” that Audacity does not export the selected audio when there isn’t any selected audio (if that is what the OP was doing).

There is no known bug in Audacity that does this. Perhaps you’ve discovered a bug that we’re not aware of, in which case, perhaps you can give us step by step instructions for how to reproduce the issue?

OP was suggesting the same thing as I, as far as I recall… having a track selected and having the Export selected Audio option greyed out… no?

And as mentioned, I have not yet been able to determine the exact steps to guarantee the same thing happening, or I would have posted those steps.

I’ve been using Audacity for at least 6 years, probably more, and hadn’t encountered this before. Wondered if anyone else had had the same thing as us two.

Since this is new behavior (in my amateur but lengthy experience), And since this is behavior that doesn’t seem to be correct, I am assuming it is a bug.

I’d love to be wrong, though, and that there would be some new setting that woukd correct this behavior.

Thanks for clarifying barto2.

If it happens again, try saving the project and give it a new, unique name.
Then close and re-launch Audacity.
Then open the saved project and see if you can export.

If you can’t export, then we’ve probably got a reproducible bug to investigate.

Steve, thanks for that. So far it’s been behaving normally - I can’t reproduce the odd behavior! We’ll put it down to user error, I guess, unless/until it happens again. (at which point I’ll try what you suggested)

Thanks again.

I too am a long-term amateur user, and faced this issue for the first time ever today. But I was using a 2 hour long wav speech file. As suggested, I saved it and reopened it, and now it exports selected ok. Thanks. But I reckon I have previously exported selected audio without saving it first. However I don’t mind having to save it first. Windows 10, 64-bit, Audacity 2.1.3

You shouldn’t have to save it first, but doing so can work around a number of problems. For example, if the original project is stored on a disk where there is minor damage to the disk, then making a copy will put the new saved copy on a different part of the disk. A freshly saved copy of the project should also be “clean” (no orphan files) and fully resolved (no dependencies).

Often, this type of problem is just a one-off, but if the problem happens multiple times, you should check the computer’s storage medium (hdd or SSD).