Exporting does not complete

Hi there, I’m running 2.3.3 on Windows 10. I’m trying to export my Audacity project to an audio file (.mp3, .wav, none of it is working) but the process is not completing. At times, Audacity has closed completely. Other times, it has displayed the error message “failed to read from a file in F:”. Sometimes, the export process simply stops with no error message. I am still able to save the project and play it back. Exporting, however, will not work, regardless of the file type.

I have copied the project, saved it as a new file, saved it in various locations, reinstalled Audacity, and even tried it on a different computer (also running Windows 10) but the problem persists. The project folder (and export destination) is currently on an external hard drive with 430 GB of free space, and the file name is simply “47” so I know it’s not an issue with space or file name.

Any suggestions would be great! At this point, Audacity is unusable for me.

That’s probably the problem.
Does it work if you first copy the project to the internal drive and run it from there?

As a point of interest, how is drive F:\ connected to the computer?

I copied the project folder (and saved a second copy) both to my documents folder and my desktop, neither time worked.

Drive F:\ is a USB port.

What didn’t work? What was the error?

I can select export (to .mp3, .wav, does not matter) and choose my file destination, the export in progress window opens, and then it gets halfway and just stops exporting. The project remains open, there is no error code, the export window simply closes.

Perhaps it has finished exporting(?)