Exported .wav files compatible across operating systems?

Hi!

I’m running Audacity (2.0.5) on a mac, both the mac version directly in OSX (10.7.5) and through Parallells Desktop 9. I run Windows 7 and on that I run the same version of Audacity as on OSX (but for Windows obviously).

I’m using a program under Windows 7 to analyze the sound files I record using Audacity. To begin with, I recorded the audio with the mac version and then tried to open the .wav files I exported from Audacity in my waveform analyzer. It didn’t work and I started looking for mistakes I had made. The sample rate was 44.1, which is supported by the waveform analyzer, the files were mono recordings and they were exported using the standard wave export protocol in Audacity (the waveform analyzer only accepts .wav).

I tried different approaches, using a different recording device and then using Audacity to convert the files to .wav. That gave me the same result. Then I installed Audacity on Windows 7, recorded a similar sound file, exported it as .wav and tried to open it in my waveform analyzer and it worked!

The .wav files recorded with Audacity(mac) can be played in iTunes, VLC and can be opened with Audacity(mac) but they can not be opened with Audacity(Windows) or be used with my waveform analyzer (it’s called eTimer if you’d like to know).

Is there something I’m missing here? Why would a generic audio format that doesn’t allow settings to be made in the exporting process play on one system but not on the other? An weirder yet: why would it work when recorded on the other system and then play on both?

I know of no reason why Audacity 2.0.5 on Windows cannot play a WAV exported by Audacity 2.0.5 on Mac (I have just tested it, using real machines on Windows 7 and Mac OS X 10.9.2).

The WAV exported by Audacity on Mac is Little Endian, just like WAV’s produced by Audacity on Windows.

What is the exact error given when opening the Mac-exported WAV in Audacity on Windows?

I suggest you make an example file that we can have a look at. Keep it under 1 MB (a few seconds long) then you can attach it here. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1 .

The only likely issue I can think of is an issue with using virtualization, but if so it seems more like a bug in Parallels than Audacity.


Gale

The error message states the file path and then just “failed to open”.

The virtual machine aspect occured to me as well but as the files recorded through the Windows version (where drivers and protocols are interpreted and patched through via Parallells and thus would be more susceptible to glitches and bugs) work just fine I it seems strange to me that it should be something to do with Parallells.

I’ve attached a file recorded and exported with Audacity(mac). It’s the tick of a mechanical watch movement.

The file opens fine on Windows 7 (real machine).

What is eTimer? I found http://www.softpedia.com/get/Others/Miscellaneous/eTIMER.shtml but I have no idea how to open WAV files in that.

I suggest you pursue your issue with Parallels, or dual boot Windows and Mac OS X.


Gale

eTimer is a software for analyzing the escapement mechanism of mechanical watch movements http://www.delphelectronics.co.uk/products.html

I’ll look into Parallells, it might be something to do with the file path.

Thank you for your help!