Export to WAV creates a clipped noise file (SOLVED)


Firstly, to the developers, thank you for this great project.

Regarding the WAV export issue, I’ve confirmed this on beta 1.3.13 unicode and the latest v2.0.0 unicode on windows XP SP3 x86

I am editing a 16bit PCM 44.1khz MONO WAV file of a lecture, originally recorded in sound forge.

No problems opening, editing, processing and saving the project to an aup file, (I see the edits are individual files in .au format)
but any export to WAV signed 16bit PCM results in a file of pure noise at maximum amplitude. (occurs in both v1.3.13 and v2.0.0)

If the exported WAV file is loaded into Audacity it displays as a solid red bar.
I tested in Winamp and the file is nothing but noise/hiss/static

Exports to MP3, AIFF, OGG and FLAC formats are O.K.

I have not tested the other formats, I’ll assume they are fine, the problem is with WAV export only it seems.

I see the edits are individual files in .au format

Not quite. The .au files do not necessarily follow the edits, they’re not a formal sound format, they alternate left and right, and the first two are pictures. You should not be inside the _data folder. One false step and the show turns to trash. The _data folder and the associated .aup management text file need to be in the same directory or folder to open the show.

Does the show come out the right length? If you start with a fresh Audacity and Generate > Tone the same length as your show, does that export to WAV?


That was just an observation of what I saw in those folders,
I’m not saving to or modifying anything in those folders.
I noticed them when every wav file I exported was trashed, but reloading the project file showed all my edits intact.

The noise files are exactly 46:30min in length, same as the edit.

I just generated a 440hz tone 0.5 amplitude and exported to wav, reloaded in editor and no clipping, plays fine.

The problem seems to be with the handling of existing wav files.
The file was originally exported from sound forge 6.0

The problem seems to be with the handling of existing wav files.

The problem may be they’re not WAV files. Do you have Windows set to show you file extensions?

– Hidden File Extensions
– Start > My Computer > Tools > Folder Options > View > [ ] Hide Extensions for Known File Types (deselect)
– Apply (to this folder) or Apply to All Folders
– OK

Alternately, you can get Windows to show you what it thinks the file is.

Right-Click > Properties > Extra or Summary.

Audacity will occasionally open a file it has no business opening and you don’t get into trouble until later.
You can install the FFMpeg software from the download site and that should make Audacity actually recognize and manage far more different formats than without.



I never hide file extensions…

I’ve edited spoken word using sound forge, wavelab, etc. since 1996
The file was recorded in Sound Forge v6.0, a professional editor.

Windows summary tab:
Bit Rate 705kbps
Audio Sample Size 16 bit
Channels 1 (mono)
Audio sample rate 44khz (44.1khz)
Audio format PCM

At any rate I found the problem, a wav header meta data issue.
I know there are differences in the wav file header and amount of extra data that some editors add, but if I’ve ever
had problems in the past it was too long ago to recall, so after doing some recent editing after many years
it didn’t occur to me.

Btw, the damaged noise wav files do not have summary info.

The problem was a meta data field ‘Software’: Sonic Foundry Sound Forge 6.0
I cleared all fields and saved, the resulting wav file is fine, so it is an issue with wav file metadata.

Looking with a hex editor, the sound forge files have some meta data at the end of the file.
I haven’t looked up the wav format spec, to see if that is non-standard.

So there’s one for the Faq if anyone else has this problem, clear the wav meta data when exporting.

Yes that’s non-standard and is a known problem with Sound Forge 6 files. The WAV export library that Audacity uses chokes on that extra metadata.
As you’ve already discovered, the way to work around the issue is to clear the metadata.

The issue is listed in the Audacity release notes:

WAV or AIFF exports may either generate a “Libsndfile says” error or be low volume, distorted or unplayable if you import a file having metadata following the data, or there are other issues with the metadata content. Workaround: Click File > Open Metadata Editor, press “Clear” to empty the metadata, then export. If you are on Linux and see “Libsndfile says”, you could try updating to libsndfile 1.0.25 then recompile Audacity against that.

(the release notes are available during the installation process, but hardly anyone ever reads them :wink: )

I’ll mark this issue as “Solved” which may help others with the problem to find the solution.