Export multiple tracks too long [SOLVED]

Hello, I am very new to Audacity. I am in the process of converting audio cassettes to mp3. I was successful in my first attempt and it came out great. I followed the same steps on my second attempt and I ran into a problem. I broke the recording up into several tracks. Then, when I exported the tracks, it showed the first track being 47:11, 2nd track 44:45, 3rd track 41:15, 4th track 38:30, and so on down the line. When I play the track, it plays fine. The problem is after the track is finished playing, there is a lot of dead air at the end of the track (44:45 minutes of dead air after the the 1st track, 41:15 minutes of dead air after the second track, and so on). I apologize if that doesn’t make a whole lot of sense but that’s the best I can explain it. Can someone tell me how to adjust the proper track times for the length of the track???+Thank you!

Please tell us what version of Audacity you are using (all three numbers, see the pink panel at the top of the page).

If you using Audacity 2.1.1 or 2.1.2, there is a bug that sounds like the issue you are having. The bug can occur if you use Export Multiple and have Audacity tracks stacked on top of each other and labels as well. Either Export Multiple using multiple Audacity tracks without labels, or use one Audacity track with labels.

If it is the same bug, we have now fixed this in the source code so it will be fixed in the next release of Audacity.


I am using 2.1.2. When I select the tracks option, it will export the first two tracks only. Not sure how to use one Audacity track with labels. I have included some images to clarify what I’m doing. Thanks for your help.
Pic 1.PNG
Pic 2.PNG

If you need to cease recording to change the tape over, you would press Pause rather than Stop, which keeps the recording on one Audacity track. Then add labels at the track divisions as per http://manual.audacityteam.org/o/man/splitting_a_recording_into_separate_tracks.html.

As it is now, you do have a label track somewhere or you would not have an option to export multiple by labels. Try DOWN arrow to go to the bottom of the project and delete the label track if you are not using it.

If only two tracks export when you export multiple by tracks, how many Audacity tracks do you have stacked on top of each other? If you have one Audacity track for each track on the cassette, make sure all the tracks are unmuted.

Due to the bug I mentioned, if you export multiple by tracks and any tracks are a little to right of time zero (0.0 on the Timeline), then you might export overlong tracks. If that is the problem, select the first track by clicking above Mute/Solo, then Tracks > Align Tracks > Start to Zero. Repeat for the other tracks.

If you are still stuck, please do CTRL + F and CTRL + SHIFT + F, then attach an image of the project window. You can use the Windows snipping tool to do that. See How to attach files to forum posts.


Thank you very much! With your help, I was able to work around that bug.