Export Multiple Problem

Hi I’m using Audacity 2.1.1, on a laptop running Windows 7, I think it was the zip I downloaded from sourceforge.net.

Ok, I’ve searched the tutorials, the FAQ, and several pages of this forum, and can’t find anything about my exact problem…

I have been using Audacity for several years, and something I have done many, many times, is add labels onto a project, to then ‘Export Multiple’ and have the single block of audio saved as separate tracks, as denoted by where the labels were added.

(This may or may not be relevant, but I recently had to completely reformat my computer, which meant I had to re-download Audacity. I don’t know if that means there is some preference that I had changed before the re-download, but I have searched and searched and can’t see what it would be.)

So… I have an audio project which I have divided into 10 tracks using labels. I then go to ‘Export Multiple’ as normal. After a minute or so, I noticed that the exporting process seemed to be taking a very unusually long time for each track…

Once it was finished, I checked the exported tracks and discovered the problem:

For some reason, each track starts at the correct point i.e. where the label was added. But, when the music stops, the track continues on in silence, seemingly for the equivalent amount of time that was left remaining in the project.

E.g. The whole project is 24 mins, 33 seconds long, so:

Track 1 - 22:03
Track 2 - 19:11
Track 3 - 17:07
Track 4 - 15:03
Track 5 - 14:01
Track 6 - 12:10
Track 7 - 08:47
Track 8 - 07:45
Track 9 - 04:40
Track 10 - 02:26

I’ve tried doing region labels instead, no difference.

I’m aware I could select each section and export each track individually, but it’s a little more inconvenient. As I said, I’m not doing anything different to what I’ve done a hundred times before, so I’m baffled.

If anyone could shed any light on this I’d be very grateful.



when the music stops, the track continues on in silence, seemingly for the equivalent amount of time that was left remaining in the project.

Someone else posted a similar symptom. I can’t wait to find out what the problem is.

Does it work if you explicitly select a song and File > Export Selected?


Ok, I got around the problem by mixing and rendering down to one track, then the multiple export worked. :slight_smile:

Would still like to know the reason it failed originally though…

Wait. Weren’t they originally all on one track?

If they’re all on separate tracks, then each track only has one label. It never hits another one and so the default export halt is the end of the project.

Are we talking about the same thing?


No there were many separate tracks (see screenshot). I think I see what you’re saying, but my point is I’ve always exported multiple like this before, without mix and render, and it worked fine.

We need to wait for one of the senior elves. I don’t know. I would have bet splitting the tracks like that would never have worked.


It’s a known bug that started in 2.1.1 http://bugzilla.audacityteam.org/show_bug.cgi?id=1199.


Gale, I’m having this same problem (with v2.1.1 and Win 10 from .EXE installer). Are there certain conditions that trigger the problem? It didn’t happen to me at first, but now I’m working on a larger project (2-hrs music from cassette tapes) and started getting this. Is a fix in the works? When can one be expected? Would like to work around it if possible.

As the link says:

Export multiple by labels may add unwanted silence to exported files if multiple tracks are present that don’t all start at time zero.

You can workaround this by using Edit > Select > All then Tracks > Mix and Render to render the audio to one track, or by generating a short amount of silence at the start of each track that is offset from zero.

To avoid it happening in the first place, either Export Multiple by tracks or labels, not both. Following Splitting a recording into separate tracks (having one Audacity track and labelling the track breaks) will avoid it.


Ok, thanks. It was late and I’m a newbie and it didn’t register in my foggy brain that the link was to a full explanation.

The following is just to doc my particular facts:
I have a set of three Christmas music tape cassettes that I wanted to put on CD, and I wanted to cram as much on a CD as would go, so I captured all 3 tapes into one project, then did a Find Silences to help me get the labeling of each song done faster. This process had worked ok on the initial 1-tape project, which had 2 audio tracks (one per side).

Each capture of the 3 tapes went to a separate track, so 6 total. I did the Find Silences and then proceeded to edit the resulting labels. These, I gathered from the manual, are point labels, not region labels. There were 2 labels at the beginning so after the first export, noticing they both included the entire length of the audio track, I deleted them and added one back. Made no difference. After trying several things, I ventured onto the forum and found this issue.

Thanks for the help!

  • Nancy