Export file extension override?

Until the latest revision, you could specify the file extension of a file export in the file dialog. With v3.4.2, it seems the program uses the extension it wants, no matter what you type in. In that case, you have to go back through your exported files and manually rename them. In my case, the file is a U-Law encoded headerless format and the program will use *.raw as the extension.
My client programs want *.ul as the extension. For example, if I put in myfile.ul as the exported file name, I get myfile.raw.

Any way to override this behavior?


It’s more a stop-gap than an answer, but if (?) you’re using Windows, I can recommend Bulk Rename Utility to sort out the mess, despite its initially intimidating-looking UI. It’s free for non-commercial use.

When you call up the export menu [ File > Export Audio } you should get a dialog box with an input bar for the file name (whose suggested extension doesn’t mean much), a path bar, and a “Format” bar that has an arrow to drop down the list of possible formats.
Here you choose “other compressed files”, which will give you a selection of “Options”.
I’m sorry I don’t know what you should choose for “Header”; maybe someone else can help. What seems to be important, though, is that you choose “U-Law” in the “Encoding” choice bar. I say that because of your desire to create .ul files.
I hope that helps.

Using a different extensions only is possible via the Custom FFmpeg and (external program) export options in 3.4.2. We didn’t have it do the automatic file extensions for 3.4.0 which caused some major backlash.

This topic was automatically closed after 30 days. New replies are no longer allowed.