Export Audio: "File Not Found" or "Unable To Export"

I’m running Audacity 2.3.0 on the latest level of Windows 10 (Home edition). The EXPORT AUDIO feature is not letting me save anything. I have a stereo recording that I successfully Imported, and then used the “Effects … Change Pitch” feature to raise the Key from Eb (E-flat) to F. I SELECT ALL the 2 channels (Left and Right) and try to EXPORT AUDIO. In the Windows File SAVE box, I first tried to SAVE with a new File Name (indicating the new Key of F in the file name). I get a Message saying FILE NOT FOUND. Well, that is true since the new file name does not currently exist, but EXPORT (in past Audacity editions) would SAVE the selected audio with a NEW File Name … that’s what I want for the new version in the new Key of F. If I try to EXPORT the audio using the same (Eb named File Name), I first get the expected FILE ALREADY EXISTS / DO YOU WANT TO REPLACE message … I select YES, but then get an Audacity message “UNABLE TO EXPORT”.

I am having this same problem. I have recorded short test recordings on Audacity 2.3.0 and tried to save them as an MP3 using LAME and as a project. In both cases I was told that it could not find the file, but I had played back the audio and could see the graph, so the file was difnitely there.

I’m also having the same problem. Am running Audacity2.3.0 on Windows10HomeEdition. Downloaded Audacity2.3.0 from audacity.sourceforge.net into the Downloads folder (I refer back to this later). Appeared to install ok and started up ok. Also loaded in the Lama MP3. Was able to record 12 tracks from an LP but couldn’t save the .apa and export likewise produced the “file not found” message.
Looked at the audacity.cfg file in “user\user\appdata\roaming\audacity” and found the following lines among the many config text lines:




I then found I could save the .apa and export into the Downloads folder, so I could continue using Audacity but restricted to the Downloads folder.

I checked that all permission settings were not causing any restrictions, and then edited the Audacity.cfg file replacing the “Downloads” to “Documents”. I copied the .apa I’d saved into the Downloads, and pasted into the Documents folder; and did the same with the associated .data file.

After restarting Audacity I could load from the Documents folder - great; BUT then found I could not save or export into the Documents folder a new named .apa file. I could however still save the new .apa file into the Downloads folder. At this point I felt like throwing the toys out of the pram!

Right at the start above I mentioned that I downloaded the audacity installation .exe into the “Downloads” folder. I am now going to attempt the same download, after adjusting the browser setting, into the “Documents” folder and see if this produces a different result thus using the Documents folder instead of the Downloads folder.

Any comments/suggestions appreciated.

What is the full name of the file (including file path and filename extension)?

What is the full name of the file (including file path and filename extension)?

Sorry, I have not been able to find an answer to the situation I am trying to solve in Steve’s suggested FAQs.

I look forward to any further advice.

Hi there,

I don’t see any [Solved] post on this issue, so here’s what’ve worked for me.

The issue is with the “Fall Something” maj of windows 10 wich introduced the “Controlled folder access” feature to Windows Defender/Security if you use it.

It’s intended to protect your files from ransomware attacks but it prevents most of normal things to happend in your folders too, since windows don’t have yet an illuminated knowledge of what is a “Friendly App”.
A bunch of your apps will need this fix. In fact, anything who access folders outside of its own installation folder will need it.

Your choices here is to :
a) Disable the feature. Simple, but doing it simple is not what we want, right ?
b) Include audacity.exe in the “allow an app through Controlled folder access” option. There is even a “recently blocked app” list to ease your search.

Anyway, here is the path to find the options
Windows Home > Settings > Update & Security > Windows Security > Virus & threat protection > Ransomware protection > Manage ransomware protection > Controlled folder access.

Here you can ether
a) Disable the little brat
b) go to “Allow an app through Controlled folder access” > Add an allowed app > Recently blocked apps > select audacity.exe
Like I said, a LOT off app will need to be allowed this way for them to perform properly. Be cautious not to just bulk allow all of them. It defeat the purpose of selective access.

Hope it works for you.