Export audacity file to mp3, need help


I’ve tried dowloading Lame for Mac OS X and I’ve checked the library location and have restarted my computer after installing this to no avail. Can someone help me export my file to mp3 format?


I forgot to mention that I keep getting a window that says, “unable to open target file for writing.” Can someone explain what this means?

It probably means you put punctuation marks in your filename. Stop that. Dates can be written 20130116. Underscore and dash are the only unconditionally safe punctuation marks. Avoid all others.
Sorry. Wrote the date wrong [blushing].


Even dash can have compatibility issues if someone produces a hyphen because they think hyphen and dash are the same.

But, yet again, any character except colon is valid on Mac ( http://manual.audacityteam.org/o/man/faq_opening_and_saving_files.html#extensions )
so should not prevent Audacity exporting unless there is an Audacity bug. This assumes you are using the latest Audacity version from http://audacityteam.org/download/mac .

The known bugs in current Audacity that cause exports to fail when they shouldn’t:

  • (OS X and Linux) Entering a backslash “” in a file name when saving a project gives a “Could not save project. Path not found.” error.
  • (OS X and Linux) When using Export Multiple, asterisks (*) or question marks (?) in labels are wrongly rejected as illegal characters, and forward slashes (/) cause a false “cannot export audio” warning. Workaround: To force use of * or ? (and / on OS X), export each region with File > Export Selection instead (/ is illegal in a file or folder name on Linux).


I’m having the exact same problem!

I tried that, too. Do you recommend using a pc to transfer the aud. file and convert it to mp3. I’m now getting a message saying that my disk is full.

You tried what?

Is your disk full?

What is the exact file name that you are entering for exporting the file?

I am trying to export files to mp3. I am using Mac OSX version 10.7.5. It is a new computer and disk is NOT full. The download of the latest version of Audacity went fine, and it recognizes it in the library - I went through ALL those steps.

I named the file “test” and made sure there were no dashes or hyphens.

When I try to export the file as an mp3, I get the message “Unable to open target file for writing.”

When I try to save the file as an .aup file, I get the message “Could not save project. Perhaps /volumes/Audacity 2.0.2/Audacity/test is not writable or the disk is full.” I KNOW the disk is not full. What does it mean that the disk is not writable? How do I fix this? Any help would be MOST appreciated! Thank you!

OK, Alma I figured it out, and hopefully this will help you too…

When you go to export the file as an MP3, the Mac automatically prompts you to save it to the Audacity file, and of course, this file is full. You want to change where you save it to to the Mac Hard Drive and select wherever you want to save it to. That completely solved the problem - it saved fine! Sometimes it’s the little things we don’t notice…

Do you mean Mac prompts you to save it to the folder Audacity.app is in?

This might be expected, but the folder Audacity.app is in should not be full.

Are you perhaps running Audacity from the DMG installer? That would explain why you cannot write there.

Here are the correct instructions to install Audacity from the DMG:

  1. Double-click the downloaded .DMG to mount it
  2. Then to install Audacity, copy the “Audacity” folder from the newly mounted .dmg to /Applications or any other location of your choosing.


Joining the chorus here.

I’m using Mac OS X 10.8.2 and installed Audacity from the dmg.

I’m having trouble exporting as an MP3. (LAME was downloaded from the dmg) I get the message “Unable to open target file for writing.”

Am also relatively new to MAC (2 1/2 mo) and still learning. I’ve reinstalled both programs but keep getting that message. Have set up the library for LAME.

What do I do next?

LAME couldn’t have been “downloaded from the DMG” because Audacity explicitly does not ship with LAME included.

For help you could check the posts that have already been made by Koz and myself in this topic ( https://forum.audacityteam.org/t/export-audacity-file-to-mp3-need-help/28086/4 ).

In other words, try naming the file or folder with only a to z or A to Z letters or numbers.

Copy the “Audacity” folder out of the DMG (don’t run Audacity from the DMG) .

If you imported a file, Click File > Open Metadata Editor… and press the “Clear” button. If this helps, it would be useful if you could upload the file you imported somewhere so we can check what the problem with the file’s metadata is. Here is a site you could upload it to http://minus.com/ then gives us the web address where we could download it.


Thanks Gale.

I am admittedly a new MAC user and don’t doubt that could be part of the problem. My terminology is obviously flawed. I downloaded both Audacity and LAME separately and moved them from the Downloads folder to the Apps folder.

I’ve reviewed the thread before posting. It’s not in the way I’ve named the file which was text only.

I’ll try copying Audacity out of the folder and see if that helps - thanks very much. I haven’t imported anything. All I’ve done so far is to make a recording on Audacity. That’s easy and the editing is simple. It’s getting it into an MP3! :slight_smile: Which I know is simple too once i figure it out.



Here’s another related question. Every time I go to use LAME, I have to reinstall. The install is always successful but it seems I should not have to do this.




You must copy the “Audacity” folder out of the DMG and then run Audacity from the folder you copied to. If you run Audacity from the DMG you will have a lot of problems to deal with.

Try using the zip of LAME then you can extract the included “libmp3lame.dylib” to your Desktop and show Audacity where it is using the LIbraries Preferences. See here:
http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#maclame_zip .

Alternatively if you put libmp3lame.dylib in the Audacity folder that you copied out of the DMG, then restart Audacity, you should not need to use Libraries Preferences. Audacity will see the dylib file because it looks for it automatically in the Audacity folder.


That happens to me, too. Audacity defaults to putting work in /Applications/Audacity. It’s a folder, not a file.

OMG! I think I’ve got it!

Thank you so much! I’m still not convinced I’ve done everything correctly but I’ve done some test recordings, saved them as MP3’s in a couple different places and am able to replay them. That’s all I need to do!

Much appreciate your patience.


Good :smiley:

If you need help with something else, all you need to do is start a New Topic (top left on http://forum.audacityteam.org/viewforum.php?f=47 ) then someone will be along.