Error while opening sound device

I am using an alesis io4 to record 4 mics at once. I am able to record but i get this error when i press the play button. Please help

Is it possible that it has something to do with my sound card. I already went to control panel abd sound settings and made sure the input device was enabled.

Go to Windows Sound (Playback tab) and make sure the Realtek speakers are enabled. Then restart Audacity.

You may have to experiment. WASAPI host is still somewhat experimental. You may have to change back to MME host in Audacity to play to the Realtek speakers. Or using WASAPI, right-click over Realtek speakers in Windows Sound, choose “Properties”, then click the “Advanced” tab and uncheck the two “Exclusive Mode” boxes.

Can you set the io4 as playback device in Audacity and listen in its headphones? That might work too.


Thank you so much Gale. Switching back to mme fixed it! It wont let me record anymore after i have already clicked record once but thats ok for now. Ill just have to record in one constant stream and not stop.

Is that WASAPI that won’t let you record twice in the same Audacity session? What happens - do you see “Error opening sound device”?

What happens if you stop, but then Edit > Select > All then hold SHIFT when clicking Record again? That should record at the end of the selected tracks.

You might also be able to press Pause then Pause again to resume recording.


You saved the day again Gale (: Both of those suggestion worked. Yea Wasapi is the only one that gives me the option to record 4 audio tracks. MME and DirectSound only only lets me record 2 audio tracks. Thanks again!

Actually you are quite lucky. :slight_smile: WASAPI does allow a few devices to record multiple channels on Windows but for many devices the only way to record multiple channels is to use a recording app that ships with ASIO support.

Audacity does support ASIO but due to licensing reasons we cannot release it with that support, so users who want ASIO with Audacity have to compile the Audacity source code.

Is that problem with WASAPI totally repeatable - record four tracks, Stop then Record again and it won’t record? What happens exactly? If that is repeatable let us know and we can add it to our list of Audacity’s WASAPI problems.


I expect this will apply for some other multi-channel devices. It would be good to know which ones.

@marshall0788 perhaps you could add a note about your iO4 and using WASAPI to this topic once you have it all figured out:

I added a note about this for now to


Yea it is a repeatable error. I tried it about ten times. It gives the exact same error as when I try to press PLAY while on WASAPI. “Error while opening sound device…”

Thanks for helping.

However when you stop recording and do a second recording, does it say to check the recording device or to check the playback device, and do you see a checkmark (tick) in Transport > Overdub in the Audacity menus?

If you have Overdub on, Audacity will try to play the four tracks to Realtek as well as record from io4, so it could be the same problem as when you simply play the four tracks. If the error says to check the playback device, it is the same issue, and you might be able to solve it by setting the io4 as Audacity’s playback device if you have headphones or speakers you can connect to it.

Also if you disconnect io4, Transport > Rescan Audio Devices then set WASAPI host with Realtek for playback device, does it still give “Error opening”?