Error while opening sound device

Can anyone tell me what going here i have check everything Help

Please note it isn’t helpful to post this here. It would be better to post to the correct forum for your operating system and version of Audacity, so we could give you a targeted answer. Hence the below “canned response”.

The usual causes and solutions of this input error are below. Please read the parts relevant to yourself.

Check at Edit > Preferences: Audio I/O tab (or Devices tab in Audacity Beta) that the playback and recording devices are correctly and explicitly selected. Don’t select “Microsoft Sound Mapper” or “Primary Sound Driver” if you are on Windows. Note: on a Mac computer, Preferences are in the “Audacity” menu.

If you are recording something playing on the computer, try turning off both the “Play other tracks while recording” and “Software Playthrough (play new track while recording it)” options in the Audio I/O tab of Preferences (Recording Preferences in Audacity Beta). Software Playthrough should never be enabled when recording sounds playing on the computer.

Try changing the Project Rate at bottom left of the Audacity window: 44100 Hz or 48000 Hz should work in almost any playback or recording situation.

If you are using Audacity 1.3.9 and have Device Toolbar enabled, make sure that the Host (for example, Windows MME) is the same for both playback and recording devices. This is fixed in 1.3.10 and later; please consider upgrading.

If problems persist, exit Audacity and go to the system mixer to enable and select the correct recording device. For Windows, look at the appropriate instructions here:

You can scroll down on that page to see the Windows 7/Vista and XP system mixers.

If you are on Windows 7 or Vista, make sure you use the right-click menu in the system mixer to “Show Disabled Devices” and “Show Disconnected Devices”. Then right-click over the device you want to record with. Choose “Enable” if this is visible, then “Set as Default Device”. For a physical microphone, it’s recommended to also set it as “Default Communication Device”. Then right-click again over the required device and hit Properties. On the “Advanced” tab, make sure the “Default format” matches both with the Project Rate you chose in Audacity, and with the number of “recording channels” in the Audacity Preferences.

For Mac OS X, click Mac hard disk > Applications > Utilities > Audio MIDI Setup. On the “Audio Devices” tab, make sure the “Default Input” is set to the device you want to record with. In the “Format” boxes, match the sample rate in Hz with the Project Rate you chose in Audacity. Match the number of channels you are recording with that shown in the
Devices tab of Audacity Preferences.

For all operating systems, if you are recording with an external USB/Firewire interface or a high-end PCI card, you must similarly match the recording sample rate and number of channels in all places (the Audacity Project Rate, the system mixer and any software or hardware control panel the sound device may have).

Always make sure your sound device has the latest drivers specific to your particular computer model and operating system, as supplied by the device or motherboard manufacturer. See: