Error while opening sound device using Logitech headset

I’m trying to record the sound of my game through Audacity. I have Windows 7 32-bit and I use the Logitech G35 which I just bought a month ago after my old headset (ASTRO gaming headset) broke. I’m using Audacity 2.0.6.

I’m getting an error when I try to record. “Error while opening sound device. Please check the recording device settings and the project sample rate.” I currently have my Audacity settings at 44100 Hz through Windows WASAP recording through 2 channels stereo Logitech G35 Headset. I’ve made sure that these are also the same settings under my Windows Playback settings. My headset is set at 16 bit under Windows Playback and I can’t find an option for that in Audacity which might be causing the problem, as well as my headset has simulated 7.1 surround sound.

I hope I can find a solution to this problem or I may have wasted $100 getting this headset. If anyone has any advice, it’s much appreciated.

You probably have a grand headset, but the wrong recorder. Audacity doesn’t always get along with games very well. Try the FRAPS game recorder software.

The bit depth option in Audacity is Default Sample Format in the “Quality” section of Preferences. That’s unlikely to make any difference.

The problem is most likely that the game insists on playing the audio in Exclusive mode rather than sharing the audio with other applications. WASAPI loopback cannot record in that case.

You can try right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the Logitech then choose “Properties”. Then click the “Advanced” tab and uncheck (remove the ticks from) both “Exclusive Mode” boxes. OK and OK.

That’s about all you can do with a USB headset. With a headset that had green and pink connectors you could try recording from stereo mix using the MME host in Audacity, which is always shared.

Otherwise try FRAPS or other specialised audio software meant for game recording.


Thanks for the advice! I tried unclicking the exclusive control boxes with no effect, still getting the error.

I found that when I change the recording channels on Audacity to 8 channels, it will actually record with only the first two channels actually recording anything, and when I hit playback, it will again give me the error. If I change it to anything other than WASAP then it will allow me to playback what I’ve just recorded. If I try to export the file, it will only save it to Mono.

Also I thought I should mention that it will give me this error no matter what, even if the game isn’t running. If only Audacity is running, I’ll still get the error. Also, it will record my headset microphone no problem.

That might make some sense if this is a 7.1 headset. Audacity can only mix down to 2 channel playback. Does the headset have only one output device in Device Toolbar or is there for example a choice of stereo output and 8 channels output? If it has multiple output devices you should try all of them under WASAPI.

That is expected if all recorded tracks say mono. What you can do is delete the silent tracks using the [X] to left of the tracks, then click on the upper remaining track in the Track Drop-Down Menu and choose “Make Stereo Track”.

This is playback under WASAPI? Another thing to bear in mind is that if you are not running in Exclusive Mode, you should make the Default Format sample rate for the headset playback and Default Format for the headset recording in Windows Sound the same as the project rate bottom left of the Audacity window.

You can set Default Format for the headset playback and recording just above where you turned off the Exclusive Mode boxes in Windows Sound.


Thanks Gale, I did a little more research into the G35 Headset and its 7.1 surround sound, and it appears there is no way to switch to stereo through any software (there is a switch on the headset that will put the headset in stereo, but the computer will still use 7.1 ). If I click Configure in Windows Sound for my headset, it only shows 7.1 in the options. Apparently it conflicts with a lot of programs, and it seems Audacity is one of those programs.

Thanks also for the tip on getting the project to export in stereo. It’s a little more annoying to deal with, but at least I still have a way to record sound and be able to plug it into my video editor and make sure I have good sound with my game. I was really worried I was running out of all options because Audacity has never failed me before; still one of the most versatile recording programs I’ve ever used.

Thanks for all the advice. At this point I think I just have to look for a work-around through Logitech to see if there’s some way to switch between 7.1 and stereo.