Error while opening sound device - please HELP!

I have the current version of Audacity. When I do voice recording through an external mic, I can play it back with no problem. However, when I export the project as MP3 (to have it saved), and then try to play it again - I get an error message:

“Error while opening sound device. Please check the output device settings and the project sample rate”.

I get the same error message when uploading any other MP3 file from my computer for editing. I have checked all the settings as per the manual - all are correct.

I have never had this problem before, and been using Audacity for many years. It started with the previous version 2.0.3. Could Audacity issue a bug patch or something? If I can playback my voice recording straight away with NO PROBLEM, it means that there is nothing wrong with my output device. It means that there is an issue with Audacity when playing mp3.

This is very frustrating - I have already spent 2 hours trying to fix it, and have an urgent project to finish. I have Windows 8, 64 bit.

could someone help me fix it please?

When I do voice recording through an external mic

What’s your microphone? I mean exactly what. Part numbers. USB?


Where are you playing it? In Audacity or Windows Media Player?

I don’t see why exporting would cause the Audacity playback to fail where it worked before you exported.

The fact that you can play an MP3 in Windows Media Player or whatever doesn’t mean much, other than the device may be working - Audacity has lots of settings that can cause audio not to play. We can’t see those settings, and you have not said what your Audacity output device is.

As a possible “quick fix”, you could try fully shutting down then rebooting the the computer (not a “restart”). However you may have “hybrid boot” turned on. This is a Windows 8 feature that saves the driver and kernel states to disk, whereas it is important that you reinitialise those.

So follow these steps to disable hybrid boot before you shut down. Alternatively if you have Windows 8.1, you can instead hold the Windows key and press X, then choose “Shut Down”. This will force a clean boot rather than a hybrid boot.

As another quick fix you could reinstall Audacity and enable “Reset Preferences” half way through the installation process. Please see: for how to do this.

If the quick fixes do not help, then if you have not yet done so, I suggest you go through this Frequently Asked Question: Why do I get “Error while opening sound device”? .

In particular, did this problem start with Windows 8? If so, you may need to check that you have correct audio drivers made by the computer or motherboard manufacturer that are meant for Windows 8 64-bit and your specific computer model. Audacity is sensitive to correct drivers. Please see: .