Error running Audacity on Ubuntu Artful 17.10


I installed Audacity through the usual apt-get repos in Ubuntu 17.10. But when I run it I get the error below. So I tried installing from the community repo on the forum and I get the exact same error when trying to launch Audacity.

It seems that it is looking for libwebpmux2 but Artful now only has libwebpmux3 in its repos.

Any help would be greatly appreciated.


audacity: error while loading shared libraries: cannot open shared object file: No such file or directory


apt list audacity -a  
Listing... Done
audacity/artful,now 2.2.1-1build1~ubuntu17.10 amd64 [installed]
audacity/artful 2.1.2-2 amd64

uname -a 
Linux marrabld-XPS-13-9350 4.13.0-21-generic #24-Ubuntu SMP Mon Dec 18 17:29:16 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

When / where do you see that error?
Is that the full message?
Have you checked to see if the problem is logged on Ubuntu’s bug tracker?

I see it when I launch it from the CLI. I tried launching it from the GUI and nothing happens. So I tried from the CLI so that I could see the errors.

yes, that is the only error that I see. Are there any other parameters I can parse the command to see a more verbose output?

I did look and didn’t see anything.

Perhaps you can help out and take a look. We have very few helpers on the Linux part of the forum (usually just me), and I see there are half a dozen new posts that need looking at.

Happy to take a look but not sure my C++ is up to scratch in order to help fix problems. I can try triage some bugs if I can get it installed on my box.

I just installed from source and I get the exact same problem. :-/

Try install libwebpmux1/libwebp5 or libwebpmux2/libwebp6 from previous repo via gdebi or dpkg -i. It’s bad idea though, better use 16.04 LTS, there are less compatibility problems.

I notice on my machine ('buntu 16.04) there is a symlink from to (both in /usr/lib/x86_64-linux-gnu).
Making a symlink from to whatever version you actually have may work.