"Error opening sound device" with WASAPI loopback [SOLVED]


I just installed Audacity 2.1.0 on Windows 7 (I was still using 1.3…), to try recording using WASAPI.
Everything looks fine according to this : http://manual.audacityteam.org/o/man/tutorial_recording_computer_playback_on_windows.html

But when I start recording, I’ve got the error “Error while opening sound device. Please check the recording device settings and the project sample rate.”
I tried many things from the FAQ, changing rate to 44.1K or 48K in either Audacity and the windows sound panel, but it doesn’t work.

My soundcard is the tiny USB soundcard you get with the SteelSeries Siberia V2 headset.

Everything works fine for sound recording using WASAPI with Bandicam.

Am I doing something wrong ?

What happens when you unplug the headset and try to make it work with just the laptop built-in microphone and speakers or headphones.(You may need to mute speakers to avoid feedback.) I can hear the Windows elves telling you update to the latest sound drivers for your headset. In the event it’s an older headset, there may not be drivers.


Thanks for the reply.

I’m really really sorry for the inconvenience, I found the answer after testing many many things…
I completely forgot that this USB soundcard allow a fake 5.1 sound, but the channels on Audacity was set to stereo.
Now it works perfectly after I disable it.

(At least I get rid of this “feature”, getting this error was not a waste… :confused: )

Sorry again and thank you for the reply.