Error opening recording device

I’ve just installed Audacity 2.2.4 on my iMac OS Catalina 10.15.7. The interface i’ve installed is a Focusrite Scarlett 2i2 - 3rd. Gen.
The 4 boxes just under the menu bar are set to(from left to right) : Core audio - Scarlett2i2 USB - 1 (mono) recording channel - Scarlett2i2 USB

When Audacity opens I get a home page open. When i click on the Microphone icon & click start monitoring a window pops up stating: Error opening recording device. Error code 9986 Internal Port Audio error. I have clicked the ? and was not able to navigate to that error code or find a route to fix this issue. I used Audacity (relevant version of course) a lot about 6 years ago without any issues, and i’m desperate to be able to use it again, please help!
Paul Moon.

Try setting the recording channels to “2 (stereo) recording channels”.
– Bill

Thanks Bill, I tried that but just the same error dialog box comes up.

Go to Apple (menu) > System Preferences > Sound > Input. Is the Scarlet listed there? If you select it and input some audio to the Scarlet, does the input level meter bounce?
– Bill

Thank you, yes I’ve now got to be able to monitor the microphone to set level, but then, when i press the Red record button nothing happens, no recording! No nothing! and no way of knowing what I may be doing wrong if anything!!! reaching the stage of trying another software :weary:

Windows guy here. Does Audacity have permission to use your microphone?

See: Control access to your microphone on Mac

I hope this helps. :smiley:

Thanks, I’ve checked that, and its enabled - but i’m going around in circles. Now gone back to error opening code 9986
I’ll shut down and reboot. All seems to work using Ableton lite but I don’t like that programme very much.

Have you figured this out? I am having the exact same problem.