Error opening recording device

I have recently downloaded Audacity 2.3.3 to my Mac Air. I can record by microphone but not from a audio-technica ATLP120XUSB turntable. I get the error message “Error opening recording device Error 9997 invalid sample rate.”

I followed the FAQ directions and tried to match input and output via these instructions :
In Finder, choose Go > Utilities > Audio MIDI In “Audio Devices”, select in turn the required Recording and Playback devices. Set “Format” to the same sample rate, bit-depth and number of recording channels as in Audacity.

In the drop-down menu I was unable to select 2 channel 24 bit integer 44110 hz (16 was the highest bit integer value offered.) Still the same message.

I toggled the output selector on the turntable from line to phono in case that helped but it did not.

Please advise.

In the Mac Sound settings, do you see the recording meter dance to the music when you play a record?

No, but I can see it in the Sound section of the System preferences.

I just reread your question. I think the answer is Yes given that you were asking about the Mac Sound settings. I was thinking about the Audacity sound display.

Yes, that’s what I was asking.

In the Mac settings, does it say the “sample rate” and “number of channels” that the ATLP120XUSB has in the recording settings?

No Steve, It just provides name (USB AUDIO CODEC) and type(USB).

Which version of macOS are you running?

Mojave 10.14.6

Have you granted permission for Audacity to use the “microphone” as described here:
(Although it says “microphone”, this actually applies to all and any recording device)

Hi Steve: Sorry I did not see the solution, Steve. It showed that Audacity had access. But I clicked it on and off and it solved the problem.

Thanks VERY much. I will proceed to the donate button.

Glad it’s working for you :smiley:
Donations are purely optional, but are very much appreciated as they allow us to continue providing Audacity for free.