Error opening recording device [SOLVED]

I’m trying to record from a USB Turntable to my computer. This worked the last time I tried it on 4/22/2018. Now I’m getting Error code: -9999 Unanticipated host error. I’ve been working through the help site for this subject.

Audacity 2.3.0
Audio Host: MME (Same error with Windows DirectSound)
Recording Device: Line (USB Audio Codec) (same error with Microsoft Sound Mapper)
Recording channels: 2 (stereo) Record (same error with Mono)
Speakers (Realtek High Definition)
Project rate: 44100 Hz
Overdub and Software Playthrough Off

Windows 10 Home version 1803 OS build 17134.285
All sound drivers updated. Speakers Properties 16 bit 44100 Hz and devices enabled
Alienware_X51_R2 64-bit 3.4 GHz 16.0 GB
Turntable Audio-Technica AT-LP60-USB


First thing to try is a complete power-down of the computer (usually “Shift + Shutdown”), then restart and try again.

Thanks for your good idea. In my case, I’ve been fighting this for two weeks and have had complete shutdowns many times.

Does Audacity play OK?
When exactly does the error message appear?

I can play files I’ve recorded before. The error message appears when I press the record button.

Have you checked that the USB Audio Codec is enabled in the “privacy settings”? (see:

It works now. Thank You!!
The only change I made was Settings/Privacy/Microphone/toggle on “allow apps to access microphone”
Your help is very much appreciated.

Excellent :slight_smile:
I’ll close this topic now.