Error opening recording device, fresh install MacOs

Installed Audacity on MacOs Catalina 10.15.7 Got the latest Audacity update as of 5 April 2023.
Recording device is set to USB audio device. Device is connected via USB and is playing.
Getting error code 9986 Internal PortAudio error.

Sometimes when this error pops up a Transport > Rescan Audio Devices will fix it.

Found mention of rescan in the Transport section of the manual, which directs the reader to the Device Toolbar. How do I access the Device Toolbar? I don’t see it.

Thanks for your time.

It’s a menu item. Transport (menu) > Rescan Audio Devices.

Found it. No joy. Getting same error code.

Let’s back up a bit. Open System Settings, Security & Privacy, Microphone. Is Audacity listed there?

Now go to Sound in System Settings and look at the Input tab. Is your USB device listed there? If you play something through the USB device does the sound meter bounce?

No, Audacity is not listed in System Settings → Privacy and Security → Permissions ->microphone or anyplace else in Permissions.

In System PREFERENCES → Sound, Audacity is not listed but USB Audio Device is, and the input level meter is active when device is played. I don’t believe anything useful is being recorded because the time and input meter in Audacity is a flat line.

This is complicated by the fact that my computer stopped producing any sound output months ago. Would like to be sure a recording has actually been created before I burn a CD.

At least we know the input is good. That’s progress!

In Audacity, change the input to the internal microphone, then hit Record. You might get a macOS system message about giving Audacity permission to use the microphone - allow it.
To Apple, “microphone” means any audio input device.

I just noticed that you’re on Catalina. I don’t recall if “microphone permissions” existed back then.

I set input to internal microphone. Input level meter is no longer active. No joy on attempt to record.

Check the recording level slider. It is integrated with the recording meter so it is easy to miss. Set it to maximum then try recording from the internal microphone.

Still get error -9986 Internal Port Audio error. Input level snaps back to zero.

I have never seen or heard of that happening when using the Mac internal microphone.
Getting desperate here: try Tools > Reset Configuration.

Went to tools → reset configuration and clicked on the button. Nothing seemed to happen. Am I missing something?

Since the sound output on my mac is getting lost somewhere it’s tempting to think the sound input could be getting lost as well. BUT system preferences → sound → input meter is very active when input is set to usb audio device and the device is playing. I suppose the input could be good but is getting lost at some point.

Sound output was lost after an update months ago. I’ve tried to correct it with help from a mac forum, unsuccessfully. Maybe I need to try harder. Resetting the mac to factory settings might do the job, but restoring it from backup would be a major pain.

Are you still getting the error or is it just no audio being recorded?

If the former, then try rebooting. If the latter, double check that the slider is turned up on your Recording Meter Toolbar as Bill suggested: Meter Toolbars - Audacity Manual

Have tried rebooting previously to try to fix the “no sound out” problem. Will try it again this evening. A complete reset to factory settings may be in order.

Successfully burned internally stored MP3s to a CD. This argues against the “no sound out” problem being related to “no input to Audacity”. Do you agree? BTW the cd unit is external to the mac.

I have no further suggestions.

Thanks for trying…xxxxxxxxxxxxxxxx

This topic was automatically closed after 30 days. New replies are no longer allowed.