Error Opening Recording Device Error: 0 Success


Is anyone else having this problem whenever you hit the red record button to begin recording with Audacity?

This just happened out of the blue. One day Audacity was fine, the next, this window will pop up saying:

" Error Opening Recording Device Error: 0 Success "

I’m lost. I use Windows 7, 32 bit. Never had this problem before.

Thanks so very much.


Please see:


Thank you, WC. I forgot to mention that I had tried using both MME and Windows Direct Sound, and the same “Error Opening Recording Device Error: 0 Success” pops up. I have even tried earlier versions on Audacity, and get the same results.

However…when I opened Audacity this a.m… in the area circled in red, something different happened this morning. When I clicked on the arrow circled in green, something new appeared in that browser window that read something like “Microsoft Maper”, and I clicked on it, and the problem seems to be solved, and I can still use the “Windows WASAPI” to record, rather than switch to MME or Windows Direct Sound. I do not know if this will work using microphones, as I have not tried it yet, but it will record directly from the computer with no problems. I didn’t memorize exactly what it said in the window circled in red, so cannot recall the other word that was part of the description, but I am pretty sure it had a third word in the title.

Thank you so much for your reply and your help.


I find that I have to have the correct settings before I open audacity. If there’s ever an error message like the one you got, I close the program, check my system sound settings, and reopen it.