Error opening recording device. EC-9999 Unanticipated host error

I’m using Windows 10 and Audacity 2.3.2

none of the fixes I’ve read about are working for me. the updates screwed me up this week. I just updated to Audacity 2.3.2 last night and still no luck. the one thing I’ve noticed that isn’t listed is that it mentions Audacity as an app (the only one) that isn’t affected by turning on access to microphone for all apps. i’m trying to record overdubs on an existing project with external mics hooked up to my Komplete Audio 6.

here’s the explanation of why Audacity doesn’t work but unfortunately I need a translator.

“Desktop apps are a specific type of app that won’t ask for permission to access data associated with privacy settings in Windows 10 in the same way that a Microsoft Store app does. Some desktop apps may not even ask for permission to get access to personal data stored on your device. Desktop apps also won’t appear in the list of apps in the privacy settings pages that allows you to choose which apps can use data associated with that privacy setting.
What are desktop apps? They’re usually downloaded from the internet or installed with some type of media (such as a CD, DVD, or USB storage device). They’re launched using an .EXE or .DLL file, and they typically run on your device, unlike web-based apps (which run in the cloud).
Please read the privacy policies of any desktop app you install to learn more about how they might use personal data stored on your device. You should also check if the desktop apps you have installed have provided their own options to control access to personal data. To further reduce the risk that an app or service can access personal data when a privacy setting is off, you should only install apps and services from trusted sources.
There are varying degrees of exceptions to how a desktop app may access and use personal data on the device beyond the privacy controls available in Windows 10.Location. Even when you’ve turned off the device location setting, some third-party apps and services could use other technologies (such as Bluetooth, Wi-Fi, cellular modem, etc.) to determine your device’s location with varying degrees of accuracy. Microsoft requires third-party software developers that develop apps for our Microsoft Store or develop apps using Microsoft tools to respect the Windows location settings unless you’ve provided any legally required consent to have the third-party developer determine your location. For more comprehensive protection of your location, you could consider disabling radio-based components of your device such as Wi-Fi, Bluetooth, cellular modem, and GPS components, which might be used by an app to determine your precise location. However, doing so will also impair other experiences such as calling (including emergency calling), messaging, internet connectivity, and connecting to peripheral devices like your headphones.
Camera, Microphone, and other privacy settings tied directly to a peripheral device. Some desktop apps may not be affected by turning off these privacy settings. For example, an app that also installs a driver could interact directly with your camera or microphone hardware, bypassing the ability of Windows to control the access. For more comprehensive protection of your personal data associated with these settings, you could consider disabling these devices, such as disconnecting or disabling your camera or microphone.
Other privacy settings. For other privacy settings not mentioned above, there are no steps you can take to ensure desktop apps do not access personal data without your awareness unless you choose not to install or use the app.”
Audacity mic (4).jpg
Audacity mic (2).jpg

A cousin forum posting got a similar error by trying to record a Stereo show with Audacity set for Mono.


I thought I saw his error code was 9997? anyway, all I have to do to get this problem to go away is tell the computer to shut off the Komplete 6 and change the Audacity input setting back to the built in mic on the laptop and it’s fine. I don’t want to record anything with that mic, so that’s my problem.

I got it solved. windows sound control panel. Realtek audio or KOMPLETE 6. clicked on KOMPLETE 6. It worked. thanks for all your help.