Error opening file on a network share


I have installed Audacity 3.0.2 on my Mac (Big Sur 11.3) and I try to open a file on an SMB mounted device (Synology NAS) where I have read and write rights, but I get this error message:

12:04:00: Error: Could not parse file "/Volumes/clouddisk/SynologyDrive/macbookpro/Elektronik-2021/03-HalbleiterDiode_01/audiop1.aup3". 
Error: Failed to set safe mode on primary connection to /Volumes/clouddisk/SynologyDrive/macbookpro/Elektronik-2021/03-HalbleiterDiode_01/audiop1.aup3
12:19:45: sqlite3 message: (3850) disk I/O error in "PRAGMA main.synchronous = NORMAL;PRAGMA main.journal_mode = WAL;PRAGMA main.wal_autocheckpoint = 0;"
12:19:45: Failed to set mode on /Volumes/clouddisk/SynologyDrive/macbookpro/Elektronik-2021/03-HalbleiterDiode_01/audiop1.aup3
	Error: disk I/O error
	SQL: PRAGMA main.busy_timeout = 5000;PRAGMA main.locking_mode = SHARED;PRAGMA main.synchronous = NORMAL;PRAGMA main.journal_mode = WAL;PRAGMA main.wal_autocheckpoint = 0;
12:19:45: DBConnection SetDBError
	ErrorCode: 10
	LastError: Failed to set safe mode on primary connection to /Volumes/clouddisk/SynologyDrive/macbookpro/Elektronik-2021/03-HalbleiterDiode_01/audiop1.aup3
	LibraryError: disk I/O error

I previously tried also to save a file on this network share and it does not work (although Audacity does not give an error message, it simply returns to the edit screen and does not change the name of the edit (e.g. the title of the window does not change to the new filename) ).

When I do all the operations locally and move the files back and forth to the network share, it works fine (i.e. no problems with read/write permissions, network connection is fine). I just noticed that in the privacy settings “Files and Folders” → “Audacity” is only allowed to access “removable volumes”, but I am able to browse the directories etc. I also gave Audacity full drive access at some point and I still get the same error.

I tried to google for “Audacity primary connection” and I only found another user (but on Windows) who has the same problem ( ), so I am not sure, what to do now.

Any ideas or insights?


It is highly recommended to copy or move the project to a local drive before opening in Audacity. This has always been the recommendation for Audacity projects, but the new project format introduces additional obstacles to using network drives for “live” (open) projects:

Networked drives may not support secure SQLite connections, locking of tables or records, or other features required for reliable transactions.
A shared network folder is even more risky as the database could be corrupted if more than one user attempts to connect to the project at the same time.