Error message "FFMPEG not found in your path" (SOLVED)

Hi everyone,
I have used Audacity for many years and found it very useful. Last week my desktop was playing up and I had to uninstall and reinstall some programs including Audacity. I am running Windows Pro 11 vers 21H2. I have installed Audacity 3.1.3 64-bit and the 64-bit version of FFMEG from the recommended site.
Now when I try to export a file to Apple Lossless, using the string recommended <ffmeg -i - -acodec alac “%f”> I get an error message “ffmeg not found in your path”. It was working perfectly up until I reinstalled Audacity.
I tried trashing the .cfg files. If I go to “Preferences/Libraries” it shows the set of numbers indicating that FFMEG is installed and recognised. I installed Audacity and FFMEG on my laptop and I get the same error message.
I have attached the Audacity log.txt file, and also screenshots of the Preferences/Libraries window, the FFMEG folder in Windows, and the Export window showing my settings.
Any suggestions please?
Audacity Export window.png
Audacity FFMpeg folder.png
Audacity library location.png
Audacity log.txt (7.17 KB)

This is just a guess but since you are using it as an “external program” try including the full path to FFmpeg in your command.

Or, export as FLAC and then use Kabuu Audio Converter (or other application of your choice) to make an ALAC. WAV may be OK too but if you have metadata (tags) WAV doesn’t always reliably support metadata.

Unless that’s just a typo, try with “ffmpeg” instead of “ffmeg”.

Hi Steve, yes that was just a typo in my message post. The screenshot of the export window has it spelt correctly.

Hi DVDdoug, the export to Apple Lossless was working perfectly up until last week. I am digitising a large box of DAT tapes for a friend. These are location recording from the 1990s. I had done about 100 tapes up until last week.
Interestingly, I have found that none of the metadata I enter in Audacity makes it across to the .m4a Apple Lossless version of the file - I save as .wav first, then save as .m4a. I have been using “mp3tag” software to copy the metadata from the WAV version to the ALAC version.

Is my issue an issue with just the 64-bit version of Audacity and FFMEG? Should I uninstall those and install the 32-bit versions?

A very kind person on Discord has given me the solution.
When you download and install the “FFmpeg_v2.2.2_for_Audacity_on_Windows_64bit.exe” installation package, this DOES NOT install FFmpeg.exe, only the .lib files.
So you have to go to the FFMpeg website and download one of the packages from there. None of them seem to contain an installer, so I just unzipped the package and copied the “.exe” files from its “bin” folder to C:/Program Files/FFmpeg for Audacity which is the folder created by the Audacity recommended installer file.
Now it works!

Leo has always been very helpful. Glad you got it sorted. :smiley:

I was facing the same issue. Thanks so much AJRYan for the fix. This solved the issue, However Now Each time as export completes, a popup appears having this information. My question is how to disable this popup? Thanks

"ffmpeg -i - -movflags +faststart “D:\Fiverr\Order 701 mharthid Batch 06\AA MASTERED BOOKS\aaa books to be updated\Enchanted objects\m4a\book 23 (enchanted objects) Part A - synopsis.m4a”

ffmpeg version N-109745-g7d49fef8b4-20230202 Copyright (c) 2000-2023 the FFmpeg developers
built with gcc 12.2.0 (crosstool-NG
configuration: --prefix=/ffbuild/prefix --pkg-config-flags=–static --pkg-config=pkg-config --cross-prefix=x86_64-w64-mingw32- --arch=x86_64 --target-os=mingw32 --enable-gpl --enable-version3 --disable-debug --disable-w32threads --enable-pthreads --enable-iconv --enable-libxml2 --enable-zlib --enable-libfreetype --enable-libfribidi --enable-gmp --enable-lzma --enable-fontconfig --enable-libvorbis --enable-opencl --disable-libpulse --enable-libvmaf --disable-libxcb --disable-xlib --enable-amf --enable-libaom --enable-libaribb24 --enable-avisynth --enable-chromaprint --enable-libdav1d --enable-libdavs2 --disable-libfdk-aac --enable-ffnvcodec --enable-cuda-llvm --enable-frei0r --enable-libgme --enable-libkvazaar --enable-libass --enable-libbluray --enable-libjxl --enable-libmp3lame --enable-libopus --enable-librist --enable-libssh --enable-libtheora --enable-libvpx --enable-libwebp --enable-lv2 --disable-libmfx --enable-libvpl --enable-openal --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenh264 --enable-libopenjpeg --enable-libopenmpt --enable-librav1e --enable-librubberband --enable-schannel --enable-sdl2 --enable-libsoxr --enable-libsrt --enable-libsvtav1 --enable-libtwolame --enable-libuavs3d --disable-libdrm --disable-vaapi --enable-libvidstab --enable-vulkan --enable-libshaderc --enable-libplacebo --enable-libx264 --enable-libx265 --enable-libxavs2 --enable-libxvid --enable-libzimg --enable-libzvbi --extra-cflags=-DLIBTWOLAME_STATIC --extra-cxxflags= --extra-ldflags=-pthread --extra-ldexeflags= --extra-libs=-lgomp --extra-version=20230202
libavutil 57. 44.100 / 57. 44.100
libavcodec 59. 61.100 / 59. 61.100
libavformat 59. 37.100 / 59. 37.100
libavdevice 59. 8.101 / 59. 8.101
libavfilter 8. 56.100 / 8. 56.100
libswscale 6. 8.112 / 6. 8.112
libswresample 4. 9.100 / 4. 9.100
libpostproc 56. 7.100 / 56. 7.100
Guessed Channel Layout for Input Stream #0.0 : mono
Input #0, wav, from ‘fd:’:
Duration: N/A, bitrate: 1411 kb/s
Stream #0:0: Audio: pcm_f32le ([3][0][0][0] / 0x0003), 44100 Hz, 1 channels, flt, 1411 kb/s
Stream mapping:
Stream #0:0#0:0 (pcm_f32le (native) → aac (native))
Output #0, ipod, to ‘D:\Fiverr\Order 701 mharthid Batch 06\AA MASTERED BOOKS\aaa books to be updated\Enchanted objects\m4a\book 23 (enchanted objects) Part A - synopsis.m4a’:
encoder : Lavf59.37.100
Stream #0:0: Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, mono, fltp, 69 kb/s
encoder : Lavc59.61.100 aac
size= 0kB time=-577014:32:22.77 bitrate= -0.0kbits/s speed=N/A
size= 0kB time=00:00:19.45 bitrate= 0.0kbits/s speed=38.9x
size= 256kB time=00:00:39.19 bitrate= 53.5kbits/s speed=39.1x
size= 256kB time=00:00:59.09 bitrate= 35.5kbits/s speed=39.3x
size= 512kB time=00:01:20.27 bitrate= 52.3kbits/s speed=40.1x
[ipod @ 0000016a27ffbe80] Starting second pass: moving the moov atom to the beginning of the file
size= 787kB time=00:01:29.88 bitrate= 71.7kbits/s speed=39.4x
video:0kB audio:771kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 2.064931%
[aac @ 0000016a2981bbc0] Qavg: 187.200"

However Now Each time as export completes, a popup appears having this information. My question is how to disable this popup? Thanks

FFmpeg for Audacity has added features to help it work with Audacity. (Somewhere I read that it has “hooks”’ for Audacity, whatever that means.)

When you export, under Save as Type there is an option (external program) that allows you to use a 3rd-party encoder. I’ve never tried it but it might work more smoothly with the standard FFmpeg files.

this DOES NOT install FFmpeg.exe, only the .lib files.

Right, but that’s not “the problem”. I don’t have the EXE file and it works for me.