Error message driving me nuts. :( Please help?

This is the message:

“Recorded audio was lost at the label location. Possible causes: Other applications are competing with Audacity for processor time. You are saving directly to a slow external storage device.”

I have a MacBook Pro from 2012 and while I could update, it currently has version 10.12.6 Sierra and that should be enough according to the registration requirements on this site.

I’ve had 3 main issues since trying to connect my Zoom H4n to Audacity: software wasn’t recognizing the Zoom (since resolved - has to do with order of plugging what into what); latency issues (not sure if resolved because while I have gotten advice now, I can’t test it out because of the error message, which used to be there only some of the time); and this issue.

Can anyone walk me through the process of fixing this?

Thank you!

I’m using version 2.2.2.

Thanks for the complete information.

Are you saving to an external drive?

Go (top of desktop) > Computer. Control-Click Macintosh HD (or whatever you called it) > Get INFO.

This is mine on the current machine.
Screen Shot 2018-04-28 at 17.10.50.png
Note capacity and available are significantly large. What does yours say? Shift-Command-4 and draw a box around the info panel.

What else do you have running? If you have an older MBP, maybe you shouldn’t be running anything else while you do production in Audacity. No leaving Skype napping waiting for a call, and totally don’t leave a browser open. Do you have your toolbar along the bottom of the desktop? How many apps have that little light indicator that the app is running in the background? I used to regularly get a manager’s Mac back in operation by closing the billions of apps he kept leaving open.

And finally, Go > Utilities > Activity Monitor. Monitor the CPU.
Screen Shot 2018-04-28 at 17.19.04.png
See: FireFox Web Content. Depending on your browsing habits, that load can go over 100%. If it does that while you’re trying to edit, that can cause serious problems.

Do you have Spinning Metal hard drive or a Solid State Drive?


Have you listened near the label locations to see if audio was really missing?

What you have encountered is a new feature in version 2.2.2 that attempts to determine if there was any audio lost during recording.

Please see this FAQ for measures you can try to prevent this from happening.

– Bill

Hi there…any luck with finding a solution to this? the same thing just began happening to me today and I’m on a bit of a deadline with my project…HELP!

I have plenty of space on my 2017 MacBook Air, running the newest OS Mojave.

I try with no other applications running and it says the same message.

BUT- I did discover that this doesn’t happen when I’m recording through the computers own mic…just when I plug my Audio Techica mic in?


I have been using Audacity for seven years, never had a single issue, and just today as I was ripping some vinyl, this same error appeared.

I have a new Mac Mini (3 months old), and have been ripping on it with no problem at all since I bought it. I have plenty of space, I’m saving direct to the Mini’s local HD, and run no other programs while ripping. So I was super frustrated to see this error pop up! I racked my brain, updated the OS, unplugged the external HDs, and nothing worked.

As a last resort, I remembered that I recently changed my wired internet connection to wi-fi and wondered if that could possibly be the issue – and it was! What’s strange is that I changed to wi-fi three weeks ago and have been ripping regularly since with no problems.

Looks like Audacity finally just got fed up with competing with my internet browsing (which I do whilst ripping). So if you tend to browse using wi-fi, this could be the culprit. Hope this helps!

I was experiencing this issue also. Turned off wifi and used ethernet instead.
Thanks for the advice…