Error message after updating to latest audacity

Win 11 64 bit
Audacity 3.1.3 64 bit
Always record at rate 44100

Recently updated to the latest audacity. I’m not certain whether my old audacity was 32 bit or 64 bit.

Immediately started getting the following error message whenever I try to do virtually anything on track recorded/saved under previous Audacity eg time shift, cut, copy, solo or mute a track.

Error message appears twice each event and is -

‘Sequence has block file exceeding maximum 262144 samples per block. Truncating to this maximum length.’

It makes Audacity unusable right now. Anyone have any ideas/solutions

Thanks to everyone.

Wow, I’ve not seen that for a long time.

About 11 years ago, there was a bug in Audacity 1.3 in which block files could be too big. The bug was mostly fixed in 2011, with additional changes over the next couple of years to catch edge cases.

Oversize block files can cause data loss, so Audacity 1.3.14 and later versions (including the current 3.1.3 version) check the size of each block file. The warning message indicates that an oversize block file has been found, and Audacity is truncating the file to a valid length.

In short, it looks like those projects contain invalid data that was created by a bug in an ancient version of Audacity.

I’m not sure how well Audacity can repair this kind of damage, but something that you can try:

  1. Quit Audacity and restart (so that Audacity has a clean starting point)
  2. “File menu > Open” and select one of the problem projects
  3. When the project is fully open; “File menu > Save Project > Save Project”
    Audacity will save the project in the new “.aup3” format.
  4. Close Audacity and restart
  5. Open the “.aup3” project that was saved in step 3

Does the new “.aup3” project work correctly?

thanks so much for taking the time to reply. I’ll definitely give your idea a go. Just to be complete though, this is a music project recorded entirely in version, I believe, 2.3.2 (or maybe one iteration earlier in the 2 series).

If your suggestion doesn’t work I’m fortunate to have saved it under that older version and I’ll just re-intall it I guess.

Thanks again. fingers crossed.

Sadly your idea didn’t fix the problem and, in doing it, I realised that I’d already done those steps and the file was already in aup3 format. Could it have anything to do with going from a 32 bit audacity to a 64 bit audacity and trying to open something in the new format that was recorded in the old one?

Unless more ideas pop up here I’m going to try the latest 32 bit version and if that fails I’ll just go back to audacity 2

Thanks again for trying.

I don’t see how that could cause this problem, especially as many thousands of people have recently updated from 32-bit Audacity to 64-bit without this issue.

A slight variation of those steps that you could try:

After opening the project (step 2) and before saving it again (step 3), select the entire project (“Ctrl + A”) and then amplify by 0 dB.
Amplifying by 0 dB effectively does nothing (same out as went in), but it may provide Audacity with an opportunity to replace the bad block files with (good) new ones.

Ah well, worth a try but no success. In fact, whether i amplify it by zero or give it a small amount like -0.1, it generates an error message and it gives me option to send it to audacity which I did. Error is -

“timestamp”: 1657638957,
“event_id”: “7535005f9a6d1c479b548c208267f805”,
“platform”: “native”,
“release”: “audacity@3.1.3”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.22621”
“exception”: {
“values”: [
“type”: “Internal_Error”,
“value”: “Internal error at line 128.\nPlease inform the Audacity team at https://.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false

I think I’ll go the old tried and true root of uninstall reinstall this version, if no luck I’ll try the latest 32 bit version and if still no luck I’ll just go bac to my old series 2 version. Thanks for the help and ideas.

If that works, try updating to Audacity 2.4.2 (the culmination of the 2.x series).

Thank you Steve, I appreciate your input.