Error: Invalid sample rate.

macOS Mojave Version 10.14
Audacity 2.3.0


I need some help. I am trying to record a voiceover with Audacity but an error appears every time I hit the “Record” button. Everything works when I try recording without a microphone and headphones but when I plug in a mic and try to record, an error appears saying “Error opening recording device. Error code: -9997 Invalid sample rate”. I clicked the “?” and tried doing all of the suggestins but I can’t seem to find the problem. Can someone please help?

What microphone and headphones are you using? Can you enable them in System Preferences / Sound?

– Bill

I am using a Blue Yeti USB microphone and Beats Pro headphones. I did enable the microphone like the manual said that came with the mic. I don’t think there is a way to enable the headphones. I just plug them in the mic and they work.

Oh wow, it just started working. I switched from “Mono” to “Stereo” and it let me start recording, even though I tried doing that before and it didn’t work then. Anyways, how do make it record in “Mono”? I don’t want it to be “Stereo”. Is there anything I need to change in the “Audio MIDI Setup” app or the System Preferences?

You shouldn’t have to do anything in Audio MIDI Setup. You should also be able to record in mono. Try switching it back. Otherwise you can record in stereo, split the channels then delete one.
– Bill