Error: Internal PortAudio error

I just installed windows 10 and booted up Audacity and now I receiving this error
Full Dialog box:

Error Initializing Audio

  • Could not find any audio devices. You will not be able to Play or record audio.

Error: Internal PortAudio error

No audio devices show up in preferences
what I’ve done so far.

  • reinstalled my audio driver

  • Rescanned audio devices under the transport menu

  • Reinstalled Audacity

Is windows 10’s new audio api the culprit here?

Audacity does not officially support Windows 10 yet.

If you have not already done so you should go to the web site of the computer manufacturer or motherboard manufacturer and see if you can find the latest audio drivers for Windows 10 meant for your specific computer model. If new drivers are there, these might be better than the audio drivers that Windows 10 found itself.

The situation is fluid, so also keep using Windows Update and use Windows Device Manager from time to time and try the right-click option over the audio device to update the drivers.

If that does not help please see for other things you can try.


I upgraded to Windows 10 over the weekend and got the same message:

"Error Initializing Audio

could not find any audio devices.
You will not be able to play or record audio.

Error: Internal PortAudio error"

would upgrading from Audacity 2.0.6 to the current version resolve this?

Upgrading to Audacity 2.1.1 will probably not fix the problem.
Upgrading your sound card drivers to a version that is designed for Win 10, probably will fix the problem, but then you should update to the latest version of Audacity.


I upgraded to Windows 10 too, and…

I have the same issue, my MB is an ASUS m2n-sli deluxe (very old one), and I have 2 sound cards installed, the MB internal one and the AVID MBox Mini 3rth gen (USB). so I decided to turn off my computer, and unplug my AVID MBox mini, then start my computer with MBox mini unplugged, and Audacity recognized the internal card!!! … AVID still hasn’t updated the drivers, but strangely Pro Tools works OOTB with its hardware (MBox mini) in windows 10, and the MBox mini control panel recognizes the driver and hardware without issue!!.. … the point is that may be it has something to do with the USB cards, and the fact is that If I connect both, Audacity cannot see any. … I have not tested yet using only the USB card.

I hope this gives a clue

Indeed, that is an Audacity bug that only occurs on Windows 10. It’s stated clearly on the Windows 10 OS - Audacity Wiki page.

Probably not too strange. ProTools is expressly designed for MBox. Audacity is not expressly designed for MBox, indeed strictly we have never supported MBox.

I would expect it to fail if there are no Windows 10 drivers for it yet.

Thanks for the input.


Thanks Gale Andrews for your replay

Well, Asus hasn’t update its drivers too (SoundMAX ADI1988), and the audio is working!!
but I went to device manager in W10 and they’re using one from microsoft.

I’m going to disable the internal card from BIOS and will see what happen.



I turned off the internal audio card in the BIOS, and I left the MBox mini plugged in, and surprise!!
It works … Audacity recognized the card!! … record and playback. … my conclusion is that there is a bug (in my case)
that audacity can’t manage USB and internal audio card at the same time!!

We have not seen that before, that Audacity would recognise the internal motherboard device on its own, and the external USB device on its own, but not both together. That isn’t a general issue - many users on Windows 10 can use an external USB audio device and the motherboard device together in Audacity if Audacity recognises each device on its own.

The much more common problem is that if one device is not recognised, none of them are. It is possible if you had ASUS-supplied Windows 10 drivers for the motherboard device that Audacity would recognise the MBox at the same time.

But as I say, Audacity does not officially support MBox at all. And both your devices (ASUS motherboard and MBox) do not yet support the version of Windows you are using.

Thanks for the input.


Hey hey hey … hey

Something really strange happened …

after the foregoing, I enabled both cards and I decided to do a last test, …so I set the mbox mini as default (right click over the left down audio icon > playback devices … Recording devices > select mbox mini and set as default.) … I started Audacity, and recognized everything!!! … so I set back internal card as default, and audacity recognized everything too!!!

My conclusion is that the last things I did have nothing to do with it, but when I disabled and enabled the internal MB card in BIOS, something was moved (may be the order they are loaded, Or windows 10 reinstalled the drivers … I don’t know) … but now it’s working with both!!!


Now I’m happy for Me, I hope everyone else solve this soon, I don’t think I have any solution, but for now you can tray to unplug (USB or PCI) or disable, cards in BIOS, start windows, turn off windows again, Plug-in or enable your cards again, start windows, and see what happen.

Thanks for the update. I wonder if that arrangement will survive the next reboot? :slight_smile:

If you have changed the BIOS, Windows may very likely do a deeper re-initialisation than otherwise. The default “Shut Down” is by default not a “cold boot” - it retains the original kernel session for reuse next session.

You can check Device Manager to see details of the current motherboard audio driver files or Reliability Monitor to see if it has any information on a recent driver update.


I don’t know if the problem has been permanently solved for me but after upgrading from Windows 7 Pro to Windows 10 on a little box with a Realtek card built in the MB and a Behringer U-control external card, Audacity had stopped working with the Internal PortAudio Error. I removed the external card and still no luck. I tried using Audacity in Windows 7 mode, still no luck.

Then this morning I uninstalled the Realtek driver (despite Windows saying it was the latest and didn’t need updating) and rebooted.The Realtek driver was reinstalled at boot but the card not set as the default device as it had been before the driver was uninstalled. And voila! I opened Audacity, no more error and it never sounded better booming out the Altec Lansing speakers. I haven’t reattached the Behringer USB as yet nor have I rebooted. Happy :smiley:

What do you have as the default device, the disconnected Behringer?

For most people we’ve heard from, if only one device is incompatible with Audacity and that device is disabled, it only takes a restart of Audacity for it to recognise the compatible device.

It would be useful diagnosis if the problem was that Audacity needed to see each device separately as default device to recognise all of them, but (at the moment) your experience suggests the opposite. Let us know what happens when you enable Behringer and reboot.

Of course it is always possible that Windows did not install the same “up-to-date” drivers for the motherboard device as before.


No. Originally in Windows Sound, Stereo Mix (Realtek High Definition Audio) was the default and that worked under Windows 7, alongside Behringer or vice versa. It was still the default after the upgrade to Win 10. Since deleting the Realtek driver and restarting the machine, no default is set in Windows Sound. It is however recognised by Audacity and accessible as an option (also listed in the Audio Device Info)

Without rebooting, I plugged in the Behringer and restarted Audacity and recording was again not available BUT, the Internal PortAudio error message did not pop up as in the past. All devices were recognised by Audacity and accessible as an option (also listed in the Audio Device Info).

I believe the problem is with Windows and not Audacity because there was no playback from a Youtube video while Behringer was plugged it. Once I removed the USB, sound spewed from the speakers. Probably those IRQ problems of the good old days of Windows 3.x - 98 etc?

It’d be good to see which sound cards report the highest number of conflicts.


Hmm. In my experience, if some recording device is enabled, there should be a default recording device. Otherwise, Windows Sound Recorder or any other app that cannot choose its recording device would not be able to record.

Does Windows Sound’s “Recording” tab still show no Default Device and no Default Communication Device?

Stereo Mix would almost never be default recording device on a fresh driver installation - often it would be disabled and hidden. I could possibly believe that if someone upgrading over previous Windows had stereo mix as default, where stereo mix was buggy under Windows 10, it could cause issues for Audacity, but that would not have caused Audacity to fail all good devices under previous Windows.

As above, I do think there is an Audacity problem here which we will have to look into. Audacity should not fail all devices unless all are incompatible, and doesn’t do that on earlier Windows.

Losing sound on the computer when a USB device is plugged in is well known on all versions of Windows, but it only happens because the newly plugged in USB device becomes default playback device.

If you make the motherboard audio default playback device, then disconnect the USB device, Windows remembers that and so will not make the USB device default playback device next time you connect it.


Sorry, the mic was assigned the default recording device by Windows Sound, and Stereo Mix (Realtek) was listed as “Ready”, along with a virtual mic. To me it’s odd though that the USB board disabled the internal one because I had plugged it in originally (under Win 7) to play around with a DJ console that uses multiple inputs. There wasn’t any interruption to either the DJ application, Audacity or any other audio video application back then. When I’m finished with some other things I’ll fiddle around with the sound set up to see what’s what.