Error Initializing Audio

Hi all,
I am trying to use Audacity and keep getting the error “Could not find any audio devices” / “Internal PortAudio error”
I am using windows 10 (build 10240), 64 bit and Audacity 2.1.1
I also have a Fousrite Scarlett Solo but have tried Audacity with and without the Solo installed and cannot find any newer audio drivers. I have disabled and reinstalled the audio drivers but still nothing.
Anyone have any other thoughts on next steps?

Focusrite has a Windows 10 compatibility checker at As you can see there, Scarlett Solo on Windows 10 requires the 2.5.2 driver. Do you have that?

However if Audacity fails with the Scarlett disconnected that also means that the built-in sound device does not have proper Windows 10 drivers. Have you followed the advice on That is, have you been to the web site of the computer or motherboard manufacturer to look for the latest Windows 10 audio drivers for your computer model?

Or have you tried the other solutions listed farther down that page under “Internal PortAudio error”?

If you need help with that, please tell us the make and model number of your computer.


It shows Driver Version: 10.0.10240.16384 but I uninstalled it and downloaded the 2.5.2 and reinstalled and it now shows the same driver 10.0.10240.16384. Also tried to uninstall the Solo completely to see if Audacity will work with the built in realtek mic and speakers and still no device found either way.

Hi Gale,

Thank you for your quick response. Turns out disabling the built in realtek mic and speakers did the trick.

So now you can only use the Scarlett for audio?

If your computer maker does not offer Windows 10 audio drivers, most people who have Realtek devices have been able to use the generic Realtek drivers listed on our Wiki page


Please try and let us know if Audacity can see Scarlett with Realtek fully enabled.