Error Initializing Audio when Fast Track Ultra on [SOLVED]

A week ago I was using Audacity without any problems. Then midweek (Wed/Thursday) 11/11 or 11/12 I launched Audacity and received the message “Error Initializing Audio. Could not find any audio devices. You will not be able to play or record audio. Error: Internal PortAudio error”.
I read several posts in this forum and on http://www.tenforums.com thinking “what changed” did a patch come out? In the process of reading and trying to figure out what happened. I did the following.
I am running Windows 10 Pro 64 bit. I have been on Windows 10 now since the free upgrade in August with no issues related to Audacity.
I was on Audacity 2.1.0 and I upgraded to 2.1.1
I updated my Realtek High Definition Audio drivers to Version 6.0.1.7655 11/3/2015.
I saw one post about RealTek HD Manager not have the Default Format set. I checked that and it was okay.
I have sound produced through iTunes, Internet music streaming so everything checks on that.
Because I play music I use Cakewalk Sonar and use M-Audio Fast Track Ultra USB audio interface. I decide to power that down and to my surprise Audacity came up without the error message and it showed the Audio Device info.
I have not Personally installed any new programs or updates on this computer except for what I mentioned above. I did notice that there have been some Windows patches installed recently but nothing Windows 10 related. Just Printer, MS Office and Windows Malicious Software Removal Tool. Still, I suspect Windows and I will post to TenForums this same message.
Any thoughts?
Thanks

As described on Windows 10 OS - Audacity Wiki, current Audacity has a problem that if one connected audio device does not have Windows 10 drivers perfectly matched for the device then Audacity is likely to fail to initialise any devices, even ones where the drivers are perfectly matched.

Were you running Audacity with Fast Track Ultra connected before? According to http://avid.force.com/pkb/articles/en_US/Download/Fast-Track-Ultra-Drivers Avid do not provide Windows 10 drivers for your device. Also I see here Avid Pro Audio Community - View Single Post - Fast Track Ultra 8R Windows 10 drivers? that “Windows 10 is not yet qualified for any avid products”.

What is your Windows build? Windows 10 has just had its first major update which is “Version 1511” (build 10586.3). To check version, use the search box or icon, type “Winver” (without quotes) and press ENTER on your keyboard.

Did you see any Windows notifications (Notifications icon in the system tray) that Fast Track Ultra is not compatible with Windows 10? Is Fast Track Ultra wording with Sonar?

The only thing you might try is exit Audacity, make Fast Track the default recording device and default playback device in Windows Sound, then use Power Menu or Win + X and choose Restart (not Shut Down).

Let us know how you get on.


Gale

Thanks for your replay Gale. with your post and questions I decided to uninstall and reinstall my M-Audio drivers since I had already done that with Audacity. That appears to have fixed the problem. I should have done that before posting anything.
The question in my mind is what caused it to stop working.
At this point this problem has been resolved.

How do I mark this post as resolved?

Carl

I have marked it “[SOLVED]”.

I don’t know why it stopped working, if you already had the Avid Win 7/8 drivers that are the latest available. As I say, if you had just got the Windows 10 “1511” update, that could be the reason.

Or you may have to accept that because you moved to a version of Windows that your hardware does not support, the device could behave erratically.


Gale