Error Initializing Audio (SOLVED)

When I start audacity, an error message occurs which reads, “Could not find any audio devices. You will not be able to play or record audio. Error: Internal PortAudio error.”

I am using Windows 7 with the latest version of audacity. Updated all my drivers. Used a Behringer UCA222 to connect laptop and casio privia PX-330. I can see the USB audio CODEC device from Control Panel > Sounds and have already set the recording/playback and whatnot to default. But still gives the same error message.

Any help would be most appreciated xx Please and thank you so much!~

Try “Transport menu > Rescan audio devices”.

Tried… Nothing :frowning:

Please post the output from “Help menu > Audio Device Info”

Default capture device number: -1
Default playback device number: -1
No devices found

The strange thing is I could actually listen to the playback off my computer’s speaker, and record it with window’s ‘sound recorder’, which essentially means there are no problems with the connection. Just that audacity can’t seem to find it :confused:

So which device is the default playback device and which the default recording device in Windows Sound?

If you have installed Behringer’s ASIO drivers, that is probably why Audacity does not see the UCA 222, in which case please uninstall the Behringer drivers.

Also if you have a computer speaker, I don’t understand why Audacity doesn’t see the built-in motherboard sound device? I suggest you try enabling all the built-in playback and recording devices in Windows Sound. Please see .


The USB Audio CODEC (which I assume is the Behringer), is both the playback and recording device. All my sound/recording devices have already been enabled and still no luck :frowning: I’m not entirely sure what you meant by the ASIO drivers but do you want me to uninstall all the related ‘USB Audio CODEC’ drivers which are automatically installed everytime I plug in?

Thanks xx

I suggest you unplug the Behringer for now so that is out of the equation.

We ask you at the top of the page to say exactly what version of Audacity you have (people often say they have the “latest version” but they don’t). You can look at Help > About Audacity to see the version you have, but I suggest you reinstall the current 2.0.5 with reset preferences. To do that, click this link .

Before installation, exit Audacity.

Halfway through the installation, tick (check) the box that says “Reset Preferences”. When you start Audacity, say “Yes” when you are asked if you want to reset preferences.

Post Help > Audio Device Info… as it is now, without having Behringer connected.

You may have ASIO drivers if you downloaded drivers from the Behringer web site. If so, uninstall those downloaded drivers from the Windows Control Panel.

Now connect the Behringer to the computer, choose Transport > Rescan Audio Devices in Audacity and post a second copy of Help > Audio Device Info… while Behringer is connected.


I don’t think there are any ASIO drivers installed. Under the ‘USB Audio CODEC’ Device theres:

Without Behringer,
Default capture device number: -1
Default playback device number: -1
No devices found

With Behringer and after rescan,
Default capture device number: -1
Default playback device number: -1
No devices found

And that’s with the USB Audio CODEC set as default for both playback and recording. When I press random keys on the piano, the volume levels on the microphone changes, which essentially shows it is connected? Don’t understand why Audacity can’t find it x

Sorry for being such a pain in the backside zzzzzz

Did you reinstall 2.0.5 from and perform “Reset Preferences” as requested?

If you have really enabled all your built-in devices in Windows Sound then the problem may be “updated all my drivers”. How exactly did you do that?

If you download ASIO drivers from the Behringer web site then my suggestion remains that you uninstall them using the Windows Control Panel.


Yes to reinstalled and reset preferences.
‘Updated all my drivers’ with the ‘Update drivers’ feature. (Auto-search/update from windows)
Never entered a Behringer website so would not be possible to download the ASIO drivers, if that is what you’re suggesting x


Which is not the proper way to do it. Please see: .

What you want to do is go to the web site of the computer manufacturer (if it’s a branded computer like Dell or HP) or to the web site of the motherboard manufacturer then download the appropriate audio driver that is intended for your exact computer model and exact version of Windows. If you have 64-bit Windows then you need the 64-bit version of the drivers.

If you are still stuck after ensuring you have correct drivers as above, please right-click over the speaker icon by the system clock, then choose “Recording Devices”. Attach an image of what you see there. Please see here for how to attach files: .


OMG. I reinstalled the audio drivers like you said from the lenovo website and VOILA!!! IT WORKED!!! Thanks so much Gale :slight_smile: I can’t say how much I appreciate you putting up with my poor computer skills >.> Really, thanks alot :slight_smile:

p.s. I can finally enjoy audacity