Error in audacity

I have MacOS Sierra version 10.12.6 and downloaded audacity version 2.3.3 and I can can only record 1 or 2 pinch ins before I get error code error openening sound device or error code -9986 ion kno if it is my settings or what but someone plz help.

What device are you trying to record from?
– Bill


I see a lot of reports of this error and wondered if anyone had found a sound solution. I am running Mac OS 10.12.6 and Audacity 2.3.2.

I’ve been using a USB PNP Audio Device - a tape player - and it’s worked perfectly for maybe eight months. Today I get this error. I’ve restarted the computer thinking it would reset something internally, I’ve restarted Audacity several times. My next step was to download and reinstall.

Audacity has been a great program and I’ve copied about 40 tapes = now this.

I have really loved my Mac compared to my windows machines, but this sort of thing is becoming tiresome. Audacity is not the only program that will suddenly start having problems.

Any suggestions will be appreciated.


Lots of people have trouble with those things. I’m amazed you got it to work at all. Unless something has changed recently with your Mac, I’d say something has changed with the device.

Re-installing Audacity will not do any good. See here for how to reset preferences.

– Bill

Similar issue with error code -9997. I was on version 2.3.3 (I think I know it was 2.3 for sure) trying to record from a Sony receiver. I had no problems recording on version 2.2.2. I uploaded 2.4.1 and it worked.