Error Importing mp3

Laptop: Lenovo
Windows 10 v.1803 (OS Build 17134.765)
Audacity v.2.3.2 (issue also occurred on v.2.1.0 on same PC)

I just installed Audacity 2.10 and received the error shown, so I uninstalled, and then loaded Audacity 2.3.2 and get the same error when attempting to open .mp3 files. Error occurs on Lenovo laptop running Windows 10. (However, the same files open in a Windows 7 computer running Audacity 2.10). FFmpeg is installed per the second screenshot, yet I still get the error message and cannot open the mp3 files.

Have you tried any other MP3 files? Do you have any “known good” music MP3s?

It’s probably not really an MP3 file but you can open most audio files with FFmpeg installed. Audacity can open MP3s “out of the box” with no additional CODECs. Older versions of Audacity needed LAME if you wanted to create an MP3 but that’s built into 2.3.2 so you no longer need anything “extra” for MP3s.

Check your “problem file” with [u]MediaInfo[/u]. It should tell you what the format really is, and give you some format details. A real MP3 will come back as “MPEG Audio”, “Version 1”, “Layer 3”.

Well, that didn’t tell me anything I didn’t know (unless I used it wrong).

A typical output from MediaInfo is like this:

Complete name                            : 3.mp3
Format                                   : MPEG Audio
File size                                : 330 KiB
Duration                                 : 8 s 411 ms
Overall bit rate mode                    : Constant
Overall bit rate                         : 320 kb/s
Track name                               : 3
Track name/Position                      : 3
Writing library                          : LAME3.99r

Format                                   : MPEG Audio
Format version                           : Version 1
Format profile                           : Layer 3
Duration                                 : 8 s 411 ms
Bit rate mode                            : Constant
Bit rate                                 : 320 kb/s
Channel(s)                               : 1 channel
Sampling rate                            : 44.1 kHz
Frame rate                               : 38.281 FPS (1152 SPF)
Compression mode                         : Lossy / Lossy
Stream size                              : 329 KiB (100%)
Writing library                          : LAME3.99r
Encoding settings                        : -m m -V 4 -q 3 -lowpass 20.5

Since the file is very small (maybe one spoken word?) you can attach it to your next post. Maybe we can figure out what’s going on. [u]How to attach files to forum posts[/u]

Can you play the file in Windows Media Player on the “problem computer”?

Thanks; file attached. Media Player also could not open it; it also thinks it’s corrupted (message 0xc00d36c4).

I found something interesting. I could email the mp3 files from the Windows 7 computer with a company email address to the “bad” Windows 10 computer which is a different company, and the file works fine in Audacity.

Thinking back, I’ve also had issues transferring mp4 video files to my personal computer after a Windows update. If I transferred via (a different) thumb drive. I ended up having to place the files in the Cloud in order to access them. Crazy.

That’s not a valid MP3 file.
I’m not sure what it is, but interestingly it contains some XML data:
I removed the name from this:

<?xml version="1.0" encoding="UTF-8"?>

Does that mean anything to you?
Where exactly did this file come from? I’m assuming that it’s not an Audacity recording.

You are correct: not Audacity.
It is the text-to-speech generator in Articulate Storyline 360 which creates files in an mp3 format and stores them in a library. I then exported the files to a folder on the Windows 7 laptop. The files open correctly in Audacity 2.1.0 on the Windows 7 laptop, but not in Audacity 2.3.2 on the Windows 10 laptop.

I’d guess that (XML?) file “points to” the file that stores the actual audio. I don’t know why it’s named “MP3”.

Hopefully the “real” file is also named “.MP3” and hopefully it’s a “normal” MP3. There is nothing in that file that says “MP3” or “text” so it may point-to the audio file indirectly through it’s library. I assume you used the Export Audio feature in Storyline to (attempt to) create the MP3?

Of course if this is the case, the real MP3 file hasn’t been copied from the working computer. If you can’t find the real MP3 file you may have to contact Articulate support, or maybe they have a forum.

That is a very interesting consideration! I’ll dig into the Articulate Storyline files and see what I find. Thank you for all of your detective work!

Hey there, I’m using Audacity 2.4.2, and the app always fail me when I try to import some music files into Audacity. The music is in mp3 format, and I got it from YouTube Audio Library ( ). I tried to download some files from here, and tried importing them into Audacity. It always shows that my “FFmpeg” aren’t found. I tried following the instructions to download/locate my “FFmpeg” files, but I don’t have any on my laptop. It also shows that Audacity doesn’t recognize the file type of the music file. It’s just a normal mp3 music file downloaded from YouTube Audio Library! I hope the Audacity team can solve this problem for us, since we downloaded Audacity because we want a easy-to-use DAW.

I’ve just tried 3 files at random from there, and they all import into Audacity 2.4.2 with no problem. :confused: