Error Importing Audio from Video Files [SOLVED]

Windows 10, Audacity 2.1.2 with .exe installer

I’ve been using OBS Studio to do screen/audio capture on 2 audio channels - mic and system. I then import the audio to Audacity for editing. Everything seemed to be working fine, but suddenly I’m unable to import into Audacity. I get the following error message:

Audacity did not recognize the type of the file “file”. If it is uncompressed, try importing it using “Import Raw”.

Obviously, importing raw gives me a garbled mess. I’m not sure what the issue is. I’ve tried mp4 and mov with the same result. I have ffmpeg as well as LAME installed and in the appropriate place. I even reinstalled Audacity. I’ve double checked all my settings in OBS Studio, and they all seem in order. I’m at a loss. Any ideas?

Do you have any old files from OBS Studio that worked previously? Do they still work in Audacity?

Good question. I just double checked and, yes, the old files still work fine. I opened the properties and other than the file sizes and save locations everything seems to be the same. I tried to import the new file again just in case and received a different error this time:

“file name.mp4” is an Advanced Audio Coding file. Audacity cannot open this type of file. You need to convert it to a supported audio format, such as WAV or AIFF.

I’ve double checked and my ffmpeg libraries are correct and in place.

It would seem that the files that you are now exporting from OBS Studio are in a different format from what you were using previously.
Have a look to see what formats are available from OBS Studio.

File properties won’t give you full specifics.

You can use “MediaInfo” from MediaInfo - Download MediaInfo for Microsoft Windows to compare files. Get the version without installer, because the installer may have malware or adware.

Are you using FFmpeg 2.2.2 as from FFmpeg FAQ?


I downloaded that program and all formats are the same between each file. The only thing I can see that might create an issue is that somehow my multi-track files have one audio track at 320 kb/s and the other at 160 kb/s. I’m not sure how that happened but will look into it. I’m very much a novice with these things. So, before I spend all night trying to figure out how this happened (OBS shows 320 for both), does anyone know if this is the actual issue?

My last post forgot to confirm that, yes, I am using ffmpeg 2.2.2

Also, I was able to force OBS to downgrade both audio tracks to 160 kbps and that didn’t seem to make a difference. I received the same error message. I also noticed that the bit rates were still slightly off at 160.071 kbps and 160.093 kbps. So I’m back to ground zero…

Thanks for the help so far. Is there anymore information I can provide?

You said that you have old files that work and new files that don’t, so we need to know what the difference is and hopefully then work out what’s changed.
As Gale suggested, MediaInfo will probably be able to show what the difference is, but note Gale’s warning and get the version without the installer.

If you can share an example file that fails, for example on Dropbox, we could take a look at it.

Do the good and bad files have the same number of channels?


It appears I no longer have the old files. I usually delete them after a project is complete to save HDD space. It’s possible I miss-remember and I was never able to import a multiple track file, but I’m certain I was. Obviously something must be different, but for the life of me, I can’t figure out what.

Here’s a file I’m unable to import:

I’ve tried this in mp4 and other containers with the same result. After I convert them using Handbrake to single track mp4’s with Handbrake, I’m able to import them fine. But that results in loosing one track. So, I have to convert them once per track - extremely time consuming and inconvenient to say the least.

Thanks for all the help so far. I really appreciate it!

I don’t see a problem with that file, though obviously I don’t know what audio it is supposed to contain.

There are two stereo streams of 1 minute 52 seconds. You choose which stream to open, one or both, when you import the file into Audacity. The first stream only has a click at 16 seconds. The second stream has commentary from about 20 seconds.

If there is supposed to be commentary before 20 seconds, it isn’t there.

I suggest you look at Edit > Preferences… > Libraries in Audacity and make sure Audacity sees FFmpeg. If not, browse for it in that dialogue, or reinstall it from


I get the same.

@Gale On Windows, would it be worth looking in Audacity’s “Help menu > Show Log” for this sort of problem?

The log will report details of whether FFmpeg loaded, but you can see that more easily from the Libraries Preferences. From the error that appears, Audacity seems not to be recognising FFmpeg.

The log also shows what importers attempted the file in what order, but it will only be useful to see that if Libraries Preferences is seeing F,C,U numbers for FFmpeg, which indicates that FFmpeg is loaded correctly. FFmpeg is the only importer on Windows that will properly handle MOV files.


This probably wasn’t the best example file as the system audio was all but absent. This was just a quick easy example file to share. The fact that there isn’t much audio on the tracks shouldn’t matter. It should still import multiple tracks, correct? What you saw/heard is correct. However, that doesn’t happen to me anymore. I’m unable to import anything at all and receive an error instead. I can take that exact same file, delete one of the tracks, and it will import into audacity just fine (with just one audio track). However, doing so for each track plus the video is quite cumbersome (as previously outlined) and defeats the purpose of editing multiple, synchronized tracks.

I just opened a MOV file with one track and then attempted to open a MOV file with 2 tracks right afterward and here’s the log of events:
03:05:21: File name is C:\Users\Glenn\Videos\Projects\UM
03:05:21: Mime type is *
03:05:21: Opening with libav
03:05:21: Open(C:\Users\Glenn\Videos\Projects\UM succeeded
03:05:23: Opening with libsndfile
03:05:23: Opening with liboggvorbis
03:05:23: Opening with libflac
03:05:23: Opening with lof
03:05:23: Error: Importer::Import: Opening failed.

Here is the error displayed:
Audacity did not recognize the type of the file ‘C:\Users\Glenn\Videos\Projects\UM’.
If it is uncompressed, try importing it using “Import Raw”.

Here’s an image showing my library

Not automatically. You have to select both streams if you want both streams in the “Select stream(s) to import” dialogue. Do you see that dialogue? If you select no streams and press OK, then no audio imports, and you will see the error and log message you posted.

If failing to select streams is not the issue, then what happens in the above case? Does just one stream import, or none?

Have you changed Extended Import Preferences in any way that might be confusing Audacity? If you have, delete all the rules.

Your FFmpeg looks OK from the Libraries Preferences - it has the F,C,U numbers I would expect. What does the log look like, above the part you posted, where it shows loading of FFmpeg? Did you obtain FFmpeg from the buanzo site listed in theFFmpeg FAQ, or have you self-built it?

Perhaps you could also post the exact file that gives you the error above.


Oh wow! I am such a ditz! I never actually selected the streams. I don’t know how I overlooked this the entire time. Thank you so much for the help. I’m so sorry to take up so much of your time for something so simple. But trust me, I’m an extremely happy person right now!

No problem. It isn’t as intuitive as it might be.

I will see about adding an image of that streams dialogue to the Manual.

I will mark this topic [SOLVED] and lock it now.