Error: failed to disconnect from DDE server gracefully...

Hi, every time I use audacity 2.4.2 on windows 7, upon closing all of the windows I was working with, I get two messages saying “error: failed to disconnect from DDE server gracefully: a parameter failed to be validated by the DDEML.” When I click ok it says that again.

Before you ask… I’m using windows direct sound, and a Mackie ProFX 6v3 mixer as my microphone.

I never got this message when I was using the portable audacity 2.3.3… only with the full version of audacity 2.4.2.

I tried to upgrade this PC I’m using currently to windows 10, but it failed. Since it’s a Dell Inspiron M5030, I’m going to replace it soon. In the meantime, I’m stuck with windows 7 until then.

Any suggestions on how to fix it?

The notes say Microsoft hasn’t actively used DDE since Windows 95, but modern Windows machines try to maintain backwards compatibility. Has this machine ever had Win95? Do you use applications that date back to then?

DDE has been deprecated since it’s easy for evil software to break into it and cause damage.

When was the last time you ran your virus software in the high mode where it does a thorough scan all night?


Audacity doesn’t use DDE connections. Perhaps it’s something to do with the Mackie software? Is there a correct way to shut down and disconnect the Mackie? If so, then perhaps try shutting down and disconnecting the Mackie before shutting down Audacity.

One of the problems you will have resolving this issue is that no-one supports Windows 7 any more (it’s officially obsolete).

I’ve never seen it happen with any other application. It only happens when I leave audacity open for more than 15 minutes at a time. This happens even when my ProFX isn’t even connected to that machine. I tried looking on the internet for similar solutions, but it didn’t help.

Did you obtain Audacity via the Audacity website:
Did you use the “Audacity 2.4.2 installer” or the “Audacity 2.4.2 zip file”?

Do you have multiple Audacity windows open at the same time?

As Audacity no longer officially supports Windows 7, the easiest solution, until you upgrade your computer, may be to use an older version of Audacity. See: