Error code: -9996 Invalid Device

I have had Audacity working on this computer but made changes so that I could record from the mic. Now I cannot get the original settings back. The code now shows up for any of the 9 settings available from the recording screen. I have been searching, practically in the dark. Someone please tell me where to go…

Do you have permission to use the microphone? See:

Have you rebooted your PC ?

Have you tried both MME and WASAPI ?

Do Transport > Rescan Audio Devices after connecting any audio equipment
Do Tools > Reset Configurartion to reset Audacity.

Typically, every machine will be different.

Do you have permission to use the microphone? See: … 8ca45f577a
Microphone is set to off. No longer using Microphone.

Have you rebooted your PC ?

Have you tried both MME and WASAPI ?
I tried all 9 settings

Do Transport > Rescan Audio Devices after connecting any audio equipment
Using line in.

Do Tools > Reset Configurartion to reset Audacity.
Will do.

Whether or not you actually have a physical microphone, Windows will not let you record anything unless you first allow “microphone” recording.

Windows will not let you record anything unless you first allow “microphone” recording.“”

I get a hollow sound in my recording. I figured that was both microphone and line in splashing together to offend the recording.
Maybe something else…

Well, that is progress over the -9996 error. :wink:

Nope, that was in the past.
I still have the error code.

And it is time for someone else to get involved with this…

Where did you set the microphone to “off”?

The error code “-9996 Invalid Device” comes from PortAudio, which is a software library that Audacity uses to connect to the computer’s sound system. PortAudio expects to find real (physical) audio input and output devices, and could throw this error if all real input devices are disabled.

I’m guessing that you want to record sound that is playing on your computer (though you’ve not actually said what you are trying to record). Is that correct?
If that’s the case, detailed instructions are here:

Note that if you are using “WASAPI loopback” it is essential that you select the “loopback” device that matches the sound card that your other app (such as your web browser) is using for playback. It is also essential that the sample rate matches in Audacity, Windows Sound settings, and the playback settings of the app that you are recording. WASAPI does not do resampling, so if the sample rates don’t match it won’t work.

UPDATE: Getting there…
One computer is working to some extent, At least I can record this weekend on it. It does have a drawback that maybe I should let go for not. It records and plays back however, changing the input volume slider has little to no effect on the recording level and the output volume controller has no effect. Fortunately, I can use the control on the smart speaker to change the recording volume. It is not totally working, but for now I can live with it.

The other computer records only from the microphone. The answer is probably not with Audacity as I cannot select anything other then microphone in the settings in the computer. I spent the morning twerking around but did not get anywhere. Maybe someone might tell me where to go.

Good news, I think the one computer is fully operation for Audacity.
Bad News: I have no idea how I accidentally got it working.
Badder news: The second computer remains Microphone only.
Possible good news: I have another computer to try.

Bad news, I am back to square one…
I went in to verify the recording, anything that records is apparently through the microphone only or I get the -9999 invalid device error code. All audio includes the sound of the air conditioner and anything that I say along with what is coming from the computer speaker. Any setting that does not have the microphone active gives the -9999 code.

I looked into the device manager and all entries that have a speaker icon state the the device is working. I keep hoping that it is a switch somewhere that is set incorrectly.

I have three desktop computers all giving me similar complaints. All three are Windows 10 pro. Two are identical HP “all in one” computers and the third was assembled. All have the 3.1.3 version of Audacity but I had this problem on earlier versions. I have audio that was recorded from the internet using Audacity and they play as expected.

It looks as if I am going to have to record my tracks this weekend using the best microphone setting as I can.
I spell all this out again hoping that I might have something new that I did not include previously and maybe it will strike a cord with someone.

Have you read this? Tutorial - Recording Computer Playback on Windows