Error Code -9986

I am trying to connect a new Audio Technica USB TT (AT-LP120X). I have followed all the instructions and configure the Mac (OS Catalina 10.15.7) and Audacity yet I don’t get any sound coming through my Mac any ideas?

When I click the microphone icon in Audacity I receive the following:

Error opening recording device
Error code -9986 Internal Port Audio

Do it in the Mac first. Apple (upper left) > System Preferences > Sound > Input. The microphone has to appear there and the sound meter has to jump. Do you have it that far?


Thanks Koz, I’ve tried that, I select USB Audio as the input and the microphone doesn’t appear in my Mac. It says that the selected device has no input controls.

Scott Shaw at Audacity said to go to Privacy settings in my Mac, and activate the mic, which worked. I had the same problem trying to record from a usb turntable.

I have the same problem and tried everything I knew to try. Seeing the comment above, I went to my Mac privacy settings. I clicked on the microphone and Audacity is already on for using the mike. Any other suggestions?

Check the USB lead for damage.
Check that the USB lead is securely connected at both ends.

Try “Transport menu > Rescan Audio Devices”, then check that you have the correct Recording and Playback devices selected in the Device Toolbar.

I have started to use mine and I can get the app to respond after I close the app and then reopen it again but if I continue to try and record from this file repeating the process it will work a couple of times or once if I am lucky. Then I have to close out the app again and restart the process again. I have checked my microphone and it is set to read the audacity application. I still get the error 9986 come up every time I go to record.

I have done this and I can quit the app and get to work to maybe one or two records from it reading the device and then I get the error popping up again. I close the app down and start over and it will work for another one to two recordings and stop reading the device. Know I can’t even get the app to recognize the device and my computer show it hooked up. I have been excited about using this device since I got it almost two years ago and couldn’t use it because it never supported MacOS until now. What tapes I got to record and save from my collection they great but I am not sure if I am able to use the app until this issue get resolved because I troubled shot from cable to reading my device to everyone else advice on here and I about to bag trying to figure out how to get this thing work every time I open your app to use it with my device. Thank for your help but I have already been at this point. Right now it is a hit and miss for me I either get to read the device for some use out of it our I just hang it up and go another route in converting my tapes over to digital files.

It would have been better to start a new topic rather than tagging onto the end of an old topic.

What is your recording device?

I’ve been getting this for a while, but only on my M1 Mac 2020. The application and my microphone works well on my custom made Win10Pro machine.

Audacity 3.1.3
Mac OS 12.1 on Mac Mini M1, 2020
Mic: Blue Yeti X – World of Warcraft edition.

Tried changing USB cables. Same error code. Sometimes it’ll work, but once I stop, that error code will display a few seconds after I hit the record button or ‘R’ again. Tried this on my Windows PC… works like a charm without any error codes. That error only pops up on my Mac. I could try my Macbook pro 2013? Or my older mac mini from 2014?

Audacity worked just fine on this M1 macmini just fine around late-October. No idea why it’s doing it now.